Not a great start with Fedora and Battery consumption is throuh the roof

First I had error messegase about nouveau driver but not enough info to send a report.
Could not install the Nvidia apps from the software centre to turn of Nvidia and use the integrated amd (Asus TUF A15).
Then the battery indicator also not working and now that I did the workaround from this Post Battery charge indicator broken on certain ASUS motherboards, automatic suspend doesn't work
I can see how quick the battery is draining. I was on Zorin 16 before and got (with auto-cpufreq installed) 4 - 5 hours while watching Youtube and surfing the web.
Now I get an estimate of 1 hour 50 min without doing anything (on power profile battery saving).

CPU is calm and the fans are quite. Nothing suspicious there.
I installed auto-cpufreq to test and it was even worse as the fans turned up a bit. Everything else was normal though.
I need my Laptop sometime running on Battery and this is just not possible with Fedora.
I don’t see how the difference can be that high between two distros both running Gnome (I know Zorin uses an older Gnome version). Did not have any of the other issues either (I know baterry indicator issue is a Kernel problem).

Any help or input is appreciated

You cannot install the nvidia drivers from the fedora repos.
Those are installed from rpmfusion as shown here.

It would help if you could actually show the error message about nouveau, but it is certain that if you are running the nouveau drivers and not the nvidia drivers your system is forced into software rendering instead of using the hardware acceleration that is supported by the nvidia drivers. With software rendering the CPU is tasked with doing the job of the GPU and power demand is greatly increased as well as slowing response.


Thanks for the answer.

I did the normal iso installation with automatic partitioning and checkmarked the third party packages. After the install I got like 3 of the same error messages every boot but for some reason it does not show anymore.
“Xxorg-x11-drv-nouveau Unexpected System Error” was the message. I already searched the internet and forum but if you get 3 or more different “solutions” it is difficult to understand what to actually do.
I guess I have to install the proprietary drivers but how? I have a gtx 1650.

On Zorin I think I actually turned off the Nvidia gpu as it used more power than the integrated amd.
How can I do that on Fedora?

Rpm fusion is enabled (was from the beginning).

Does anyone run auto-cpufreq?

My main issue is the battery drain. It’s 1% per Minute on cold boot doing absolutely nothing.

The rpmfusion repos are updated and synced with fedora for packages on a regular basis.

As long as you do not have packages installed from a 3rd party repo that conflict there should never be an issue. In several years I have never had a problem that was not caused by installing from another 3rd party repo and the fix has always been to remove or disable the extra repo and stick with rpmfusion.

As far as I know The best fix for the extra power demands with an nvidia GPU is to install the nvidia driver. If you refuse to do that then you will never know if the change of drivers will fix the problem or not. It is obviously your choice whether to try or not.

I did not install anything from 3rd party. I have a clean install of Fedora 36 with only the things provided by Fedora.

I now installed the Nvidia Drivers with “sudo dnf install akmod-nvidia”.
I will see how it affects the battery.

Is there a (easy) way of diabling the Nvidia GPU and only run the amd GPU?

Appreciate your help


I rebooted and unblugged the cable at 92%. It said 8 hours 15 first and now after 2 Minutes with the Browser open it says 3:59 left.
Better than 1:50 I guess. I will see if auto-cpufreq now works

Seems like the new update messed everything up for me.
Battery indicator works fine - no worries here.
Nvidia Card is active again sucking my battery empty in no time.
Prpriatery drivers are NOT installed so I can not disable the Nvidia GPU as I am not able to install the Nvidia program.
And both card are running for some reason.

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] [10de:1f95] (rev a1) (prog-if 00 [VGA controller])
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir [1002:1636] (rev c6) (prog-if 00 [VGA controller])

Before that update the fans where quiet (not rotating at all with brwosing) and my battery at least lastet for 4 hours with auto-cpufreq anabled. Now all is messed up again except for the error messages I got in the beginning.

I need a command to disable the Nvidia GPU and only run on the internal AMD but it seems hard to find one with google as most just tell to turn them off in the Nvidia settings. But I for some reason can NOT install them.