Battery drain in Fedora 34 related to GPU

Hi, Its my first post here. I installed fedora 34 workstation edition over a month ago, It worked perfectly out of the box. But whenever I reboot fedora an error pops up and said it could not be reported

It isnt a major issue, but I try to fix it by blacklisting nouveau , since I dont need NVIDIA GPU. I have intel UHD graphics and drivers were installed upon installing fedora.I ran this script from web
echo blacklist nouveau | sudo tee /etc/modprobe.d/blacklist-nouveau.conf
sudo sed -i ‘s/quiet/quiet rd.driver.blacklist=nouveau/g’ /etc/default/grub
echo ‘omit_drivers+=" nouveau "’ | sudo tee /etc/dracut.conf.d/omit-drivers.conf
sudo dracut --force

if [ -d /sys/firmware/efi ]; then
grub2-mkconfig -o /etc/grub2-efi.cfg
grub2-mkconfig -o /etc/grub2.cfg

exit 0

It resolved the issue but now I am facing a huge battery drain( only 2hrs upon full charge). I installed tlp, still no use. If I try to revert the process, I could bring back the error but not battery performance. I also did a full system upgrade, still no use. Output of
lspci |grep -E “VGA|3D”
00:02.0 VGA compatible controller: Intel Corporation WhiskeyLake-U GT2 [UHD Graphics 620] (rev 02)
02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX230] (rev a1)

Gnome version 40.4.0 and Windowing system is Wayland
What should I do to resolve the issue?

Allow the system to actually load a driver for the nvidia GPU so the driver can put it into idle state. Either nouveau or nvidia would work.

Lack of a driver allowing the card to be fully activated without being used is likely the source of the excessive battery drain.

You are definitely in the Optimus configuration and would need (without looking it up specifically) either the 340 or 390 driver for that card if you chose nvidia. The 340 driver is no longer supported and the 390 driver only marginally so.

I would first revert all the changes you did, including the dracut command and the grub2-mkconfig command to clear out the blacklisting. Then reboot and try again.

The optimus config is well documented for the nvidia driver at rpmfusion.

From what I can see, u have a MX230

Nouveau isn’t perfect, Maxwell and before are the only versions of the cards that are currently supported mostly. Anything beyond that doesn’t function properly.

You are almost exclusively reccomended to use proprietary drivers, which are offered by Negativo, RPM Fusion, etc. Fedora by default ships nouveau.

I would reccomend giving this a try as clearly, there is a nvidia gpu in ur system.

Optimus support for Linux is, not great. But still, I suppose the solution mentioned can help

Reminds me of a Lenovo ThinkPad Edge laptop with two graphic chip-sets being Intel and NVIDIA … feature simply disabled in BIOS with Lenovo update using Windows OS with noway to go back. The idea was to use Intel driver for everyday use favoring battery life and NVIDIA for specific use based on games or similar. I still use a ThinkPad today but recent model and the feature doesn’t appear in Lenovo catalog anymore. Try to explore hardware in BIOS setup …

rpmfusion worked, Now I get a decent battery. Thanks !