Steam takes a VERY LONG time to launch

When I launch Steam, the updater starts and when it’s done, it disappears. The app indicator (via the appindicator gnome extension) appears and… nothing. For 5 to 20 minutes no amount of clicking on the Steam app or the options under the status indicator will bring Steam up. It shows up in system monitor but also will take a very long time to kill. After a couple or a lot of minutes it finally shows up after clicking the app icon.

I’m using Fedora Workstation 38 and the rpm fusion Steam package. I have an nvidia gpu and the rpmfusion drivers. I have vulkan shader pre-caching and background caching enabled on Steam tho I don’t know if that would be the issue.

Any ideas?

1 Like

Not sure, but perhaps try the flathub flatpak of steam? Even if you don’t intend on using it, it should at least give something else to compare to.

Also, have you tried using steam on a different linux distribution? If so, was it faster than what you are currently seeing.

Another possible way to debug is simply launching steam through the terminal. The output can sometimes indicate issues.

when I launch it through the terminal it launches instantly…

I also tried it on Arch witch gnome and it works perfectly there too

Then I think the desktop file has a wierd command or something else is causing the launch command within the desktop file to delay.

The desktop file should be in /usr/share/applications/

Once you open the steam desktop file, save a copy of the desktop file to ensure the original is not lost. Then change the Application name to something different so that you can recognize it in the menu. Then change the “exec” value to whatever launch command you used.

Note that this solution is a hack, it may work, but won’t fix the underlying issue that caused the problem. Also should you remove steam, the copy of the desktop file probably won’t get removed on its own. You will have to do it yourself.