Steam from Flathub might not start on Fedora 38

Problem

The Steam flatpak installed from Flathub doesn’t start for many (but not all) users on Fedora Linux 38. A Steam dialog may appear briefly, but vanishes quickly and the program never starts.

Older Fedora versions seem unaffected.

Cause

It seems that Steam takes a long time to start if it can’t access NetworkManager, and gets killed it if it doesn’t have a permission to run in the background.

Related Issues

Valve report: Slow startup when not running NetworkManager and "Remember password" is checked. · Issue #4979 · ValveSoftware/steam-for-linux · GitHub
Flathub report: Cannot open Steam · Issue #1040 · flathub/com.valvesoftware.Steam · GitHub
Fedora discussion: Steam Flatpak not working on F38 beta?

Workarounds

There seem to be several workarounds:

A) Allow Steam to run in the background

Either go to GNOME Settings → Apps → Steam → Run in Background and enable it, or run this command:

flatpak permission-set background background com.valvesoftware.Steam yes

For many users this resolves the problem.

B) Run Steam in Big Picture mode

The problem seems to not happen when you start in Steam’s “Big Picture” mode. You can start it in this way from the command line, like this:

flatpak run com.valvesoftware.Steam -bigpicture

You can then leave Big Picture mode by pressing Alt+Enter. (The problem seems to be entirely with start-up).

C) Allow Steam to access NetworkManager (a security risk!)

You can give Steam access to NetworkManager, which should avoid the startup delay. However, please note the following security implications:

Note that it means Steam has access to your WiFi and potential VPN secrets. Latter means any privacy VPN can be permanently broken.

This is the command to grant the access:

flatpak override --user --system-talk-name=org.freedesktop.NetworkManager com.valvesoftware.Steam

And this is how to reset it back to defaults:

flatpak override --user --reset com.valvesoftware.Steam

You can discuss this topic here.

5 Likes