Starting: hold until boot process finishesp -Blocked and boot never goes throug

does this mean I need to install gdm? If yes, how?

Here a good article about it.

So many thanks, I had already GDM, only I enabled it and rebooted and boot process went through and login screen displayed correctly.

So couple of questions, should I keep the 30-hyperv.conf files? or shoudl I delete them
2nd, as I said I have a 2nd VM with the same issue, so I should follow same steps or not really?

3rd question which I asked earlier but no response yet, when I reboot, the boot list defaults to f34, 2nd line not f35 on 1st line, how can this be changed?

Last, where I can find a full F35 iso image to be able to install software at the beginig. when I tried the f35-live-iso, it did not allow me to chose software as usual

Of course thank you all for your efforts and helping me

In fact lightDM was setup because GDM consumed 90% of CPU when I was using Fedora 25 or 26 lomngtime ago

1 Like

Just make duplicate of your VM and try it with different approachs. It would be help other if they encounter the same problem in the future.

With all that you have gone through, the 30-hyperv.conf file did not seem to do anything so it could probably be removed.

Second VM would probably only need the switch from lightdm to gdm.

The grub menu probably can be changed by a simple reinstall of the latest kernel. sudo dnf reinstall kernel*5.15.6*fc35*

Before you do that you should do cat /etc/default/grub and verify there is a line in there that says GRUB_DEFAULT=saved. As long as that line is there a kernel install/reinstall will update the grub configuration (grub.cfg) and the last kernel installed will be the default for booting.

Just thinking about this point and your problems since the upgrade to f35 it seems likely that the upgrade did not complete cleanly since it never correctly booted after doing the upgrade, thus the grub config update was likely never done correctly/fully.

If reinstalling the kernel packages does not fix it then running sudo grub2-mkconfig -o /boot/grub2/grub.cfg should work.

1 Like

@computersavvy , I followed instructions on fedora with DNF, since I migrated f31 to 32 which finished correctly but after issuing
dnf system-upgrade rboot
the problem started so I dont really know why on my side something went wrong and upgrade was not clean, there was no erros as far as I rememeber

Yeah, the error occurred when the reboot to graphical failed. Don’t know the step of course, but it seems to not have properly reset the default boot kernel.

You should only run one of these at a time.

You may want to consider masking the one you’re not using to ensure it’s not called by anything else.
systemctl mask lightdm.service

For the downloads,

@computersavvy , none of the methods helped. I applied
sudo dnf reinstall kernel*5.15.6*fc35*
rebooted, still f34 chosen
then I applied
sudo grub2-mkconfig -o /boot/grub2/grub.cfg
rebooted did not help neither, always f34 and need to manually got 1 step up to chose f35

@grumpey , this link lands us always to f35-live ISO which suggests either to run or install, I chose install, was able to chose datetime, disk partitions… but not a page to select software and then create user as it was in earlier versions

always f35-live

Please post the output of cat /etc/default/grub

If you’d like to choose exactly what’s installed use,

The latest versions of fedora with a new install do not create the user until the beginning of the first boot where the user is created. (similar to an OEM install which does not create the user until the machine is first booted)

The Workstation version just gives a default software install with no ability to select during the install & I think Server is the same. If you want the ability to select packages during the install then you need the everything / netinstall version.

@computersavvy , here is the output for grub

[salam@puppetmaster29 ~]$ cat /etc/default/grub
GRUB_DISTRIBUTOR=“$(sed ‘s, release .*$,g’ /etc/system-release)”
GRUB_CMDLINE_LINUX=“resume=/dev/mapper/fedora-swap rhgb quiet”

That is default, so it seems strange. I would suggest waiting until the next kernel upgrade (possibly tomorrow) and see if the boot menu changes.

You also might look in /etc/default/grub.d/ and see if possibly there is a file there that has been modified which could change the default kernel to boot.

Is the VM set to boot legacy or efi? If efi, then what is the content of /boot/efi/EFI/fedora/grub.cfg? With fedora 34 & 35 it should only be about 5 lines that redirect grub to the /boot/grub2/grub.cfg file. With fedora 33 and earlier it would contain the entire grub.cfg data.

I tried to remove 30-hyperv.conf:

Click: add user to video and run startx on user session

Click: add root to video and run startx on root session

Çlick: adding back hyperv.conf and lightdm back to live


Please note, this machine using same VM with BIOS generation 1. I installed directly Fedora 35 Spin Mate using text-mode (non-gui) since when using GUI, it’s stuck on boot.

Fedora 35 Workstation (need long time to load gnome display manager) will work fine. But on livecd it fail to run in xorg (logout wayland session, go to tty with login name liveuser password blank—just enter it, and startx even after adding to video group).

@computersavvy , this VM was created long time ago and I think it starts normally not UFI, here is the contents of (3 files updated on july this year and grub on 2020

No filles in /boot/efi/EFI/fedora

/boot/grub2/grub.cfg was updated today


For default boot, run first sudo grubby --info=ALL and see the part mention index.

The latest installed kernel—by time (not the latest version), it would be have index=0.

If your lates installed was on F35 kernel, it should be have index 0.

Then run sudo grubby --set-default-index=0 --update-kernel=ALL.

The same result could be achieve with sudo grub2-editenv saved_entry unset.

edit typo

I did, here is the result, f35 had already index 0, I will reboot and see

[root@puppetmaster29 ~]# grubby --info=ALL
args=“ro resume=/dev/mapper/fedora-swap rhgb quiet”
title=“Fedora Linux (5.15.6-200.fc35.x86_64) 35 (MATE-Compiz)”
args=“ro resume=/dev/mapper/fedora-swap rhgb quiet”
title=“Fedora (5.15.6-100.fc34.x86_64) 34 (MATE-Compiz)”
args=“ro resume=/dev/mapper/fedora-swap rhgb quiet”
title=“Fedora (5.14.18-100.fc33.x86_64) 33 (MATE-Compiz)”
args=“ro resume=/dev/mapper/fedora-swap rhgb quiet”
title=“Fedora (0-rescue-1a14a952cc4c4e8ebc33948e3fb1d970) 30 (MATE-Compiz)”
[root@puppetmaster29 ~]# grubby --set-default-index=0 --update-kernel=ALL
The default is /boot/loader/entries/1a14a952cc4c4e8ebc33948e3fb1d970-5.15.6-200.fc35.x86_64.conf with index 0 and kernel /boot/vmlinuz-5.15.6-200.fc35.x86_64