Sound themes do not work under Wayland with Fedora 36 beta

The title says it all. Any custom sound themes such as “Smooth” do not work in Wayland. If I switch back to Xorg they work fine. I really would like to use Wayland but I would like to see this corrected first. Thanks.

1 Like

Could you please note down the exact steps to reproduce the issue so that some folks here on the forum can try to replicate it? If we can, the next thing to do would be to file a bug to make the package maintainers/devs aware of the issue.

Sure, just like under X11, I copy my sound theme to the ~/.local/share/sounds directory.

From there it is automatically detected by gnome tweaks, and can be selected for use.

The problem is, the sound theme is detected by tweaks, but no sounds are produced when using Wayland. If I switch back to X, the sounds work normally.

How would one test that the sound theme is working? I downloaded the linux-a11y one from here and re-did your steps, but how do I check that it’s working?

If i go to settings > sound and try “bark” etc. the sound theme in tweak tools seems to be reset/cleared. Nothing in the logs here at the moment, though…

Once you have copied the folder to the right location, open up “Tweaks” and go the “Appearance” tab. There will be a dropdown menu for the Sound theme on the right:

You will also have to have the right dconf settings. You can either edit the dconf settings from GUI or command line. Then, under X11 your sound theme should work. The same series of steps under wayland does not seem to work. These are the dconf settings:

To fully check that it is working try an action that has a matching sound, such as switching workspaces, closing a window, resizing a window, etc, etc… These are all the actions that have a matching sound in one of my sound themes:

Hrm, I did this already, but when I’d open the control centre and click on the test sounds, the setting in the tweak tool would get unset/changed. I’ll have to test it out again.

I wouldn’t go to the control center at all. I would just set the sound theme in tweaks, then go back to your desktop and do something to trigger a sound event (it will depend on your theme). Resizing windows, opening applications, closing windows, switching workspaces are some things that trigger sounds.

1 Like