Brightness Hotkeys working weirdly

I just installed Fedora 36 and the brightness hotkeys show weird behavior:

  • Pressing the “Brightness UP” key once takes the brightness to Maximum no matter where the brightness initially was.

  • Pressing the “Brightness DOWN” key once takes the brightness to Minimum.

  • In a fresh boot, after pressing both the keys, each once, None of them work again i.e. pressing them again doesn’t do anything.

  • I can still change brightness through the top bar using slider.

I tried installing Pop shell, which altered the keyboard shortcuts but then I uninstalled it and reset all “Keyboard Shortcuts” from the GNOME settings.

PS: “mod + L” to lock the PC, was also not working but it started to work after resetting keyboards shortcuts.

Any help is appreciated, I’m ready to get my hands dirty with terminal if needed.

I’ve seen weird stuff like this fixed with a firmware update before. Does sudo fwupdmgr refresh --force && sudo fwupdmgr get-updates return anything? If so, you might try running sudo fwupdmgr update when you are ready to reboot and then see if you still have the problem when it finishes.

It says no updates available

Tried Xorg session and brightness key are working normal.
So this must be a problem of Wayland.
Any clue?

If you can confirm and it is repeatable that it does not work properly in wayland but does work properly in xorg then I would suggest that you file a bug against wayland so the developers know the exact issue and hardware/software involved so they may be able to fix it.