FN Key Not Working Properly

Hi! I’m having an issue with some of the FN key shortcuts; most of them work as they should with the exception of the brightness control and a shortcut to change the screen refresh rate. This is only an issue while on Linux; all the shortcuts work fine while on Windows (I’m dual-booting).

I’m new to Linux so I’m not sure where to start. Any suggestions would help! Let me know if you need more information.

A good start for new users is #start-here

Inxi -Fzx shows what hardware and basic drivers you use. Please past such infos as pre formatted </> text.
Please tell us also which FN key shortcuts should do the change of screen refresh rate and which the brightness.

If we do have several info’s we can help to search for hints how to get that issue solved.

Alright, I’ll go through the new user page.

The Fn shortcuts for brightness are Fn+F5 and Fn+F6 to dim and increase brightness respectively and Fn+R to change the refresh rate between 60 Hz and 165 Hz.

I ran the command and here’s the info:

  Kernel: 6.0.10-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: GNOME v: 43.1 Distro: Fedora release 37 (Thirty
  Type: Laptop System: LENOVO product: 82UH v: Legion 7 16ARHA7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN
    serial: <superuser required> UEFI: LENOVO v: K9CN34WW date: 07/22/2022
  ID-1: BAT0 charge: 84.4 Wh (81.0%) condition: 104.2/99.9 Wh (104.3%)
    volts: 16.9 min: 15.5 model: SMP L21M4PC5 status: not charging
  Info: 8-core model: AMD Ryzen 7 6800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3+ rev: 1 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 544 high: 1255 min/max: 400/4785 boost: enabled cores:
    1: 400 2: 400 3: 400 4: 400 5: 1255 6: 400 7: 400 8: 400 9: 1187 10: 400
    11: 400 12: 1073 13: 400 14: 400 15: 400 16: 400 bogomips: 102212
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
    vendor: Lenovo driver: amdgpu v: kernel arch: RDNA-2 bus-ID: 03:00.0
  Device-2: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
    v: kernel arch: RDNA-2 bus-ID: 37:00.0 temp: 42.0 C
  Device-3: Luxvisions Innotech Integrated RGB Camera type: USB
    driver: uvcvideo bus-ID: 1-3:2
  Display: wayland server: X.Org v: 22.1.5 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu
    resolution: 2560x1600~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 6700M (navi22 LLVM
    15.0.0 DRM 3.48 6.0.10-300.fc37.x86_64) direct render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 03:00.1
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 37:00.1
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 37:00.6
  Sound API: ALSA v: k6.0.10-300.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Lenovo driver: mt7921e v: kernel bus-ID: 05:00.0
  IF: wlp5s0 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Lenovo driver: r8169 v: kernel
    port: 4000 bus-ID: 06:00.0
  IF: enp6s0 state: down mac: <filter>
  Device-1: Foxconn / Hon Hai Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 3-3:3
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 2.75 TiB used: 17.27 GiB (0.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 2TB size: 1.82 TiB
    temp: 40.9 C
  ID-2: /dev/nvme1n1 vendor: Samsung model: MZVL21T0HCLR-00BL2
    size: 953.87 GiB temp: 37.9 C
  ID-1: / size: 486.78 GiB used: 16.88 GiB (3.5%) fs: btrfs
    dev: /dev/nvme1n1p7
  ID-2: /boot size: 973.4 MiB used: 313.2 MiB (32.2%) fs: ext4
    dev: /dev/nvme1n1p6
  ID-3: /boot/efi size: 256 MiB used: 82 MiB (32.0%) fs: vfat
    dev: /dev/nvme1n1p1
  ID-4: /home size: 486.78 GiB used: 16.88 GiB (3.5%) fs: btrfs
    dev: /dev/nvme1n1p7
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 50.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: amdgpu temp: 43.0 C device: amdgpu temp: 42.0 C fan: 0
  Processes: 733 Uptime: 8h 31m Memory: 14.82 GiB used: 3.69 GiB (24.9%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: 10
  note: see --rpm Shell: Bash v: 5.2.9 inxi: 3.3.23

I guess the implementation between the Linux and Windows driver is not exactly the same. Have you tried to use the FN Key in combination with Shift/Ctrl/Alt keys?

Yes. No luck with that either.