Sound popping mysterious and random sound output switching

I have begun experiencing strange and very short (it feels like something around tenth of a second) popping sounds. During those pops my audio output switches from my primary audio output (3.5mm jack on the motherboard) to a secondary monitor (Technicaly a TV with inbuild speakers), which is connected via HDMI on my NVIDIA graphics card running on proprietary drivers from RPM Fusion. Curiously, this popping and output switching doesn’t accure then I switch to my secondary (TV) monitor.

I’ve never had any audio problems with any linux distrubutions (Ubuntu 18.10, Elementary OS 5, Solus) until I tried Fedora 31. I wasn’t using this computer that often so it didn’t bother me that much. I hoped that an upgrade to F32 would help, but it didn’t. I have tried many tweaks many months ago, but I’ve given up and only recently began investigating this issue again, so I don’t remember exactly that I changed, but nothing I’ve tried worked. This includes:

  • Uninstalling and reinstalling pulseaudio
  • Turning off power saving options
  • Messing with sampling rates or something similar.

I suspect, but I’m not entirely sure, it is a regression with drivers in the Linux kernel. When I started to look for a different distro I noticed the same exact problem in their live sessions: OpenSuse Leap 15.2, ArcoLinux(basically an ArchLinux installer). The only distro that has working audio is Manjaro Gnome live session build with kernel 5.6. Here’s a link with various patches that Manjaro has aplied to their kernel. I’ve taken a look at it, but I couldn’t find anything that suggests patches to any audio device driver.

I’ve atcahed a gif (currently I don’t have the permissions to upload a full video with better quality) of alsamixer and pavucontrol acting very abnormally. (In pavucontrols ‘Configuration’ tab the profile of my audio controller always changes back to “Analog Stereo Output” or “Analog Stereo Duplex” during whose pops and in the ‘Output Devices’ tab the port of my audio controller always switches to “Headphones” when popping and then switches back to “Line Out”)

Here’s my --no-upload output:

Update: I had to replace this motherboard (the old one broke) and the issue is no longer present.