Sound persistently a problem on my hardware


I am working with an ASUS ZenBook UX482EG. I have been experiencing my sound breaking across multiple distros and I am still a bit of a Linux noob.

Before hopping onto Fedora 36, I was on EndeavourOS which worked for a bit before the sound mysteriously stopped outputting through my speakers and my headset. Upon reinstalling the OS, it worked before eventually breaking again. Now the same issue has occurred in Fedora.

Before it broke on Fedora, I simply installed bspwm + sxhkd + polybar, switched over to bspwm, and worked on my sxhkd and polybar config. Upon opening YouTube, I noticed sound no longer worked. I figured maybe the sound server wasn’t started? But, within pavucontrol the sound bar was moving but no audio was coming through my speakers. I then switched back to Gnome and sound was broken there as well even though it had been working previous to logging out.

I have Googled this and attempted solutions for hours across multiple installations. It has gotten to the point where I am attempting any given potential solution in hopes it miraculously fixes the issue–and I would prefer not to do that this time because I feel like it might be breaking my settings even more.

I would be very much appreciative if someone more knowledgeable could help me troubleshoot this so I can move past this issue once and for all and get back to being productive. Let me know what command

Thanks in advance.

Here’s some basic info to start things off, Let me know what else I can provide :slight_smile:

$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 137
Tile Size: 65472
User Name: ljmill
Host Name: fedora
Server Name: PulseAudio (on PipeWire 0.3.51)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
Cookie: 7335:59a3
$ inxi -Ax
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0000:00:1f.3
  Sound Server-1: ALSA v: k5.17.9-300.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes

I don’t know how to solve your problem, but i just curious how to solve audio problem in linux specifically in fedora linux?. I use fedora since 34, I use Asus Vivobook S500CA never face problem with audio. I use pipewire and wireplumber(yes of course this is default in fedora since fedora 34). I also used to usb dac is working normally and perfectly until now in fedora linux 36.

inxi -Ax
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.17.8-300.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes

Maybe i’ll take a look at this thread.

I very often have problems logging into this site so, until now, i wasn’t able to edit the thread to mention that audio works consistently on my Windows install. I have no idea what the issue is with Linux.

I completely re-installed Fedora last night and audio was working. Upon booting up today, Audio is broken. Really not sure what the issue is. I really need to be productive so I guess I’ll try Ubuntu and if that doesn’t work stick with Windows + WSL and give things some time and try again in a couple months.