Some keyboard buttons misbehaving

Hello. I am using Fedora 37.
And recently, my OS downloaded latest update in the background and installed it.

Weird things started happening. For example:

When I am writing at somewhere, I cannot move my cursor with up/down/right/left buttons.

When I click up/down, it is controlling Volume.
When I click right/left, it is controlling Brightness.

I have already checked, keyboard shortcut settings. And any of them are configured in this way. In addition, my del button is also not working.

My question: Is there any way of fixing this issue?

Just to try to rule things out…do you see that behavior on a Live USB of Fedora 37? Or a Live USB of any other OS?

On your keyboard, is there a hardware-set combination that is related - like, is Fn+Up Arrow intended to control volume? (Thinking like a stuck key that might have happened by coincidence?)

2 Likes

Can you provide what kind of keyboard/Desktop/Laptop is being used?

inxi -FJz would also be a good place to start.

It is a laptop

I am using fedora installed on my laptop. I do not have any fn keyboard.

It is not a shortcut issue as I mentioned that I checked default shortcuts from settings. 2-3 days ago everything was working fine

I might not have explained what I meant by that - does your keyboard look like this, where some keys have additional functions mapped to them that can be accessed by holding the Fn key (usually next to Ctrl in the bottom-left corner) and pressing that key?


(image taken from a Brave Image Search for “acer aspire keyboard layout”)

If so, it’s theoretically possible that something in software is causing your PC to act like Fn is always being held down, but something physical with the keyboard is a very likely cause of this kind of issue, so it’s worth making sure that the Fn key / any of the other keys aren’t stuck or obstructed in any way.

If it’s not, it may be worth looking at some of the responses to this thread to see different options for key combinations that may help reset the Fn key’s status?

And for what it’s worth, the things I’m talking about here aren’t even related to keyboard shortcuts like what you’d see listed in the GNOME Settings app, as these aren’t seen by the PC as key “combinations” but as key inputs of their own - like there’s a “brightness up” key as far as the PC is concerned, for example.

Hope that helps! As @grumpey said, using the inxi script (might need installed via sudo dnf install inxi) and posting the results as Preformatted text (for legibility) would be helpful in any further troubleshooting.

Well, I installed the inxi
The output of inxi -FJz.

System:
  Kernel: 6.1.7-100.fc36.x86_64 arch: x86_64 bits: 64 Desktop: GNOME v: 42.6
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Laptop System: Acer product: Aspire E5-576G v: V1.49
    serial: <superuser required>
  Mobo: KBL model: Ironman_SK v: V1.49 serial: <superuser required>
    UEFI: Insyde v: 1.49 date: 12/11/2018
Battery:
  ID-1: BAT1 charge: 18.8 Wh (73.7%) condition: 25.5/29.6 Wh (86.0%)
CPU:
  Info: dual core model: Intel Core i7-7500U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 2800 min/max: 400/3500 cores: 1: 2800 2: 2800 3: 2800
    4: 2800
Graphics:
  Device-1: Intel HD Graphics 620 driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce MX130] driver: nvidia v: 525.78.01
  Device-3: Chicony HD WebCam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 1.22.1.7 with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: dri: iris gpu: i915
    resolution: 1366x768~60Hz
  API: OpenGL v: 4.6 Mesa 22.1.7 renderer: Mesa Intel HD Graphics 620 (KBL
    GT2)
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.7-100.fc36.x86_64 running: yes
  Sound Server-1: PipeWire v: 0.3.64 running: yes
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    driver: ath10k_pci
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp4s0f1 state: down mac: <filter>
Bluetooth:
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
  Local Storage: total: 1.03 TiB used: 106.24 GiB (10.1%)
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0
    size: 931.51 GiB
  ID-2: /dev/sdb model: MG BGM.2 NGFF SSD 128GB size: 119.24 GiB
Partition:
  ID-1: / size: 117.66 GiB used: 105.96 GiB (90.1%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 268.5 MiB (27.6%) fs: ext4
    dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/sdb1
  ID-4: /home size: 117.66 GiB used: 105.96 GiB (90.1%) fs: btrfs
    dev: /dev/sdb3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
  Device-1: 1-5:2 info: Lite-On Qualcomm Atheros QCA9377 Bluetooth
    type: Bluetooth rev: 2.0
  Device-2: 1-7:3 info: Chicony HD WebCam type: Video rev: 2.0
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0
Sensors:
  System Temperatures: cpu: 57.0 C pch: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 325 Uptime: 14m Memory: 15.5 GiB used: 5.75 GiB (37.1%)
  Shell: Bash inxi: 3.3.24

@johnandmegh. I made a mistake. I do have a Fn key on my keyboard. But it must not be stuck or something.

@johnandmegh

I used:

sudo showkey command.
If any key is stuck. It should have shown in the terminal

@johnandmegh @grumpey
Are there any thought on this issue?

@johnandmegh @grumpey

You may not believe that the issue disappeared. I do not know what happened internally.
Maybe you are right @johnandmegh. The Fn key was stucked. Because before checking
sudo showkey

I actually pressed that button

2 Likes

I have a funny story related to this (I have a laptop too) - a couple of months ago I could not figure out why a game I was playing (Hades) was running at a very low framerate - like the Nvidia GPU wasn’t getting used (this was on Pop!_OS, which has ‘hybrid mode’ and ‘dedicated graphics mode’).

I went through all the different ways I could think of to trigger the game to use the Nvidia GPU - setting the OS to dedicated mode, adding elements to the .desktop file, reinstalling via Steam, and I just could not figure it out. I put together an extensive post for Reddit with all the steps I had taken, my system info, etc.

Right after I submitted that post, I noticed something looked different on the end of the top bar in GNOME…it was the power icon. The place where the power cord from the laptop itself plugs into the brick (which on my model, then separately goes to the wall) had come apart, so even though I looked at the laptop itself and saw it plugged in, and looked at the wall outlet and saw it plugged in…it wasn’t actually plugged in! As a result, it was using “power saver” mode on battery. Connecting that cord back together fixed the problem!

The reason I mention this story is…sometimes all visual indications would be that a component is working and isn’t the cause of a problem, but there’s something that’s harder to see that still relates to that component and you just need some help looking for it. Hopefully it stays working for you!

If you find that you have some other sticky key issues, the first few seconds of this video may be helpful in seeing how to pop a key off of that keyboard and clean underneath (although I personally get nervous using metal tools for such things - I’ve had better luck with a guitar pick, myself!):