[SOLVED] Waiting about 1 minute to start programs in X11 Fedora 38

When I’ve upgraded F36 to F38 I see that programs (for example eog, oocalc, oowriter) start about 1 minute. No memory or CPU hardly used. Not all programs behave this way (lxterminal, pcmanfm have no problem).

I use Openbox. I’ve tried some another display managers: XFCE, Gnome Classic, GNOME. Only in GNOME I don’t waited start program. I ask me what is diffence between them? I found that in GNOME the variable XDG_SESSION_TYPE is set to wayland. Then there is no wating for start program. Maybe I mistake about a cause of the problem.

Can you suggest what I do that solve this problem for Openbox (or maybe X11)?

In Fedora 36 I have no problems like that.

I’ve run strace -tt eog if it will help (strace_eog.txt)

I solved this problem by remove rpm:

yum remove xdg-desktop-portal
1 Like

Beware that this will break flatpak apps.

There was a similar issue when xdg-desktop-portal-gnome was used outside GNOME, but that should be fixed now. If you’ve hit a related but unfixed problem, uninstalling xdg-desktop-portal-gnome would resolve it and allow you to retain the portal infrastructure. You’d also need to bring back xdg-desktop-portal-gtk.

F39 will have a further fix in that portal backends can be configured per-desktop. On F38 and earlier, x-d-p-gnome is selected over x-d-p-gtk purely because it sorts earlier alphabetically. Unfortunately, the fallback path has been removed completely, so portals will be broken by default in environments like Openbox.

Unless something changes, in F39 you’d need to create ~/.config/xdg-desktop-portal/portals.conf:


Note that this will probably break other desktops because it will override their portal configurations, e.g. /usr/share/xdg-desktop-portal/gnome-portals.conf.