Software from the Store won't uninstall

Hi folks,

A while back I installed MComix3 from Software Store, then I uninstalled it at some point, but it didn’t remove properly.

$ which mcomix3
$ sudo dnf remove mcomix3       
No match for argument: mcomix3
No packages marked for removal.
Dependencies resolved.
Nothing to do.

Here is what the Store shows:

If I press to remove:

I also tried to install with dnf and remove again, which doesn’t work. Any thoughts on this?

Are you sure didn’t install the flatpak version?

What does flatpak list show?

EDIT: I just read your post more carefully. It doesn’t look like that is the problem.

It would appear the package name is not the same as the command.
Try sudo dnf remove /usr/bin/mcomix3 which should look for and remove the package that installed that particular command file.

Alternatively you can open gnome software (which is apparently where you selected the package to install) and select the same package to uninstall.



sudo dnf remove /usr/bin/mcomix3

indeed removed the package, but the Store still shows as installed for some reason

Clicking on the trash shows the same error as before, but since it’s removed from my system, I will simply ignore this.