SMB4k (or something) freezing entire system


I’m using smb4k to mount a couple of samba drives. It seems to work, but when doing an ls or launching Dolphin, the entire system just freezes. I have to physically reboot. The system works fine otherwise. I can also access the samba drives from another computer without a problem.

I thought dolphin was screwed up, but the same behavior happens when I use a terminal to go the the mount point and do an ls. It might work once, but changing directories and doing an ls freezes. I can’t even do an ctr+alt+f3 to go to a terminal and check things out.

Help? I’ve looked in /var/log/messages, but I’m not sure what to look for.

This started happening today after the update. Probably a day or two since I last updated.

Using latest KDE Plasma spin.

Try to find out what changed with dnf history.

You can also check an older Kernel version to see if it changed since.

1 Like

I can confirm that I ran into a similar issue. After the last complete system update two days ago, the machine didn’t come up again, including older kernels. I re-installed the complete system, and the result was good until I tried to mount a samba / cifs share. The system completely freezes, I can neither access the system through the desktop nor through a ssh connection. So far, no luck retrieving any useful information from the logs…
I’m running Fedora in a VirtualBox VM, so at least I have a snapshot to go back to before the attempt to mount…

1 Like

Ditto for me on FC36. Trying to open Dolphin, GUI or via CLI, results in an immediate whole-system freeze that requires a hard boot. This started after my last update, which was last night.

[chill@chill-framework ~]$ dnf history 400
ID     | Command line                                            | Date and time    | Action(s)      | Altered
   400 |                                                         | 2023-01-05 17:48 | I, U           |   35  
[chill@chill-framework ~]$ dnf history info 400
Transaction ID : 400
Begin time     : Thu 05 Jan 2023 05:48:01 PM EST
Begin rpmdb    : b603fe43eec7095fed61b91eaefc42380f8fefd82d17b9d13a3ab03e51f01128
End time       : Thu 05 Jan 2023 05:49:13 PM EST (72 seconds)
End rpmdb      : 59b52e8c8bfb814a1997af350304f8029fb6c4bee12b49064ca9415f8e46ed43
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
    Install  kernel-6.0.16-200.fc36.x86_64                        @updates
    Install  kernel-core-6.0.16-200.fc36.x86_64                   @updates
    Install  kernel-devel-6.0.16-200.fc36.x86_64                  @updates
    Install  kernel-modules-6.0.16-200.fc36.x86_64                @updates
    Install  kernel-modules-extra-6.0.16-200.fc36.x86_64          @updates
    Upgrade  amd-gpu-firmware-20221214-145.fc36.noarch            @updates
    Upgrade  intel-gpu-firmware-20221214-145.fc36.noarch          @updates
    Upgrade  iwl100-firmware-            @updates
    Upgrade  iwl1000-firmware-1:         @updates
    Upgrade  iwl105-firmware-           @updates
    Upgrade  iwl135-firmware-           @updates
    Upgrade  iwl2000-firmware-          @updates
    Upgrade  iwl2030-firmware-          @updates
    Upgrade  iwl3160-firmware-1:        @updates
    Upgrade  iwl3945-firmware-           @updates
    Upgrade  iwl4965-firmware-         @updates
    Upgrade  iwl5000-firmware-          @updates
    Upgrade  iwl5150-firmware-            @updates
    Upgrade  iwl6000-firmware-           @updates
    Upgrade  iwl6000g2a-firmware-       @updates
    Upgrade  iwl6000g2b-firmware-       @updates
    Upgrade  iwl6050-firmware-           @updates
    Upgrade  iwl7260-firmware-1:        @updates
    Upgrade  iwlax2xx-firmware-20221214-145.fc36.noarch           @updates
    Upgrade  kernel-devel-matched-6.0.16-200.fc36.x86_64          @updates
    Upgrade  libertas-usb8388-firmware-2:20221214-145.fc36.noarch @updates
    Upgrade  libsmbclient-2:4.16.8-1.fc36.x86_64                  @updates
    Upgrade  libwbclient-2:4.16.8-1.fc36.x86_64                   @updates
    Upgrade  linux-firmware-20221214-145.fc36.noarch              @updates
    Upgrade  linux-firmware-whence-20221214-145.fc36.noarch       @updates
    Upgrade  nvidia-gpu-firmware-20221214-145.fc36.noarch         @updates
    Upgrade  samba-client-2:4.16.8-1.fc36.x86_64                  @updates
    Upgrade  samba-client-libs-2:4.16.8-1.fc36.x86_64             @updates
    Upgrade  samba-common-2:4.16.8-1.fc36.noarch                  @updates
    Upgrade  samba-common-libs-2:4.16.8-1.fc36.x86_64             @updates
    Upgraded kernel-6.0.12-200.fc36.x86_64                        @@System
    Upgraded kernel-core-6.0.12-200.fc36.x86_64                   @@System
    Upgraded kernel-devel-6.0.12-200.fc36.x86_64                  @@System
    Upgraded kernel-modules-6.0.12-200.fc36.x86_64                @@System
    Upgraded kernel-modules-extra-6.0.12-200.fc36.x86_64          @@System
    Upgraded amd-gpu-firmware-20221109-144.fc36.noarch            @@System
    Upgraded intel-gpu-firmware-20221109-144.fc36.noarch          @@System
    Upgraded iwl100-firmware-            @@System
    Upgraded iwl1000-firmware-1:         @@System
    Upgraded iwl105-firmware-           @@System
    Upgraded iwl135-firmware-           @@System
    Upgraded iwl2000-firmware-          @@System
    Upgraded iwl2030-firmware-          @@System
    Upgraded iwl3160-firmware-1:        @@System
    Upgraded iwl3945-firmware-           @@System
    Upgraded iwl4965-firmware-         @@System
    Upgraded iwl5000-firmware-          @@System
    Upgraded iwl5150-firmware-            @@System
    Upgraded iwl6000-firmware-           @@System
    Upgraded iwl6000g2a-firmware-       @@System
    Upgraded iwl6000g2b-firmware-       @@System
    Upgraded iwl6050-firmware-           @@System
    Upgraded iwl7260-firmware-1:        @@System
    Upgraded iwlax2xx-firmware-20221109-144.fc36.noarch           @@System
    Upgraded kernel-devel-matched-6.0.15-200.fc36.x86_64          @@System
    Upgraded libertas-usb8388-firmware-2:20221109-144.fc36.noarch @@System
    Upgraded libsmbclient-2:4.16.8-0.fc36.x86_64                  @@System
    Upgraded libwbclient-2:4.16.8-0.fc36.x86_64                   @@System
    Upgraded linux-firmware-20221109-144.fc36.noarch              @@System
    Upgraded linux-firmware-whence-20221109-144.fc36.noarch       @@System
    Upgraded nvidia-gpu-firmware-20221109-144.fc36.noarch         @@System
    Upgraded samba-client-2:4.16.8-0.fc36.x86_64                  @@System
    Upgraded samba-client-libs-2:4.16.8-0.fc36.x86_64             @@System
    Upgraded samba-common-2:4.16.8-0.fc36.noarch                  @@System
    Upgraded samba-common-libs-2:4.16.8-0.fc36.x86_64             @@System

I think I’m safe to assume it wasn’t the updates to firmware of devices that aren’t in my system. I’m going to roll back the entire thing to see if it fixes it, then apply the Samba and Kernel updates separately to see which, if either, caused the issue.

1 Like

Here’s my dnf history for the last update. I use samba regularly so I’m pretty sure it was something in this update. I would boot from a fallback kernel, but I have never gotten a grub menu on boot. I thuoght that was weird but haven’t had a problem so I ignored it as I haven’t been using Fedora too long.

dnf history info 83
Transaction ID : 83
Begin time     : Thu 05 Jan 2023 09:34:22 AM PST
Begin rpmdb    : 5afd9342d7df0a90d4279086af27593102e3dd4d3e229ae34d0fff12b6b1c6ab
End time       : Thu 05 Jan 2023 09:35:39 AM PST (77 seconds)
End rpmdb      : b1b5c5d0f217f1b7d2d54173316d16a972ca812f5b5c701fd18f323d08d6899c
User           : root <root>
Return-Code    : Success
Releasever     : 
Command Line   : 
Comment        : 
Packages Altered:
Install  kernel-6.0.16-300.fc37.x86_64               @updates
    Install  kernel-core-6.0.16-300.fc37.x86_64          @updates
    Install  kernel-modules-6.0.16-300.fc37.x86_64       @updates
    Install  kernel-modules-extra-6.0.16-300.fc37.x86_64 @updates
    Upgrade  bash-5.2.15-1.fc37.x86_64                   @updates
    Upgrade  btrfs-progs-6.1.1-1.fc37.x86_64             @updates
    Upgrade  coreutils-9.1-7.fc37.x86_64                 @updates
    Upgrade  coreutils-common-9.1-7.fc37.x86_64          @updates
    Upgrade  dnsmasq-2.88-1.fc37.x86_64                  @updates
    Upgrade  emacs-filesystem-1:28.2-1.fc37.noarch       @updates
    Upgrade  fluidsynth-libs-2.3.1-1.fc37.x86_64         @updates
    Upgrade  highway-1.0.2-1.fc37.x86_64                 @updates
    Upgrade  ibus-typing-booster-2.19.12-1.fc37.noarch   @updates
    Upgrade  jxl-pixbuf-loader-1:0.7.0-5.fc37.x86_64     @updates
    Upgrade  libgpg-error-1.46-1.fc37.x86_64             @updates
    Upgrade  libjxl-1:0.7.0-5.fc37.x86_64                @updates
    Upgrade  libpcap-14:1.10.2-1.fc37.x86_64             @updates
    Upgrade  libpwquality-1.4.5-1.fc37.x86_64            @updates
    Upgrade  mesa-dri-drivers-22.3.2-1.fc37.x86_64       @updates
    Upgrade  mesa-filesystem-22.3.2-1.fc37.x86_64        @updates
    Upgrade  mesa-libEGL-22.3.2-1.fc37.x86_64            @updates
    Upgrade  mesa-libGL-22.3.2-1.fc37.x86_64             @updates
    Upgrade  mesa-libgbm-22.3.2-1.fc37.x86_64            @updates
    Upgrade  mesa-libglapi-22.3.2-1.fc37.x86_64          @updates
    Upgrade  mesa-libxatracker-22.3.2-1.fc37.x86_64      @updates
    Upgrade  mesa-va-drivers-22.3.2-1.fc37.x86_64        @updates
    Upgrade  mesa-vulkan-drivers-22.3.2-1.fc37.x86_64    @updates
    Upgrade  mkpasswd-5.5.15-1.fc37.x86_64               @updates
    Upgrade  ncurses-6.3-4.20220501.fc37.x86_64          @updates
    Upgrade  ncurses-base-6.3-4.20220501.fc37.noarch     @updates
    Upgrade  ncurses-libs-6.3-4.20220501.fc37.x86_64     @updates
    Upgrade  net-tools-2.0-0.64.20160912git.fc37.x86_64  @updates
    Upgrade  open-vm-tools-12.1.5-2.fc37.x86_64          @updates
    Upgrade  open-vm-tools-desktop-12.1.5-2.fc37.x86_64  @updates
    Upgrade  python3-pwquality-1.4.5-1.fc37.x86_64       @updates
    Upgrade  python3-unbound-1.17.0-1.fc37.x86_64        @updates
    Upgrade  tcpdump-14:4.99.2-1.fc37.x86_64             @updates
    Upgrade  tpm2-tss-3.2.1-1.fc37.x86_64                @updates
    Upgrade  unbound-anchor-1.17.0-1.fc37.x86_64         @updates
    Upgrade  unbound-libs-1.17.0-1.fc37.x86_64           @updates
    Upgrade  whois-5.5.15-1.fc37.x86_64                  @updates
    Upgrade  whois-nls-5.5.15-1.fc37.noarch              @updates
    Upgraded kernel-6.0.13-300.fc37.x86_64               @@System
    Upgraded kernel-core-6.0.13-300.fc37.x86_64          @@System
    Upgraded kernel-modules-6.0.13-300.fc37.x86_64       @@System
    Upgraded kernel-modules-extra-6.0.13-300.fc37.x86_64 @@System
    Upgraded bash-5.2.9-3.fc37.x86_64                    @@System
    Upgraded btrfs-progs-6.1-2.fc37.x86_64               @@System
    Upgraded coreutils-9.1-6.fc37.x86_64                 @@System
    Upgraded coreutils-common-9.1-6.fc37.x86_64          @@System
    Upgraded dnsmasq-2.87-3.fc37.x86_64                  @@System
    Upgraded emacs-filesystem-1:28.1-3.fc37.noarch       @@System
    Upgraded fluidsynth-libs-2.3.0-1.fc37.x86_64         @@System
    Upgraded highway-1.0.1-1.fc37.x86_64                 @@System
    Upgraded ibus-typing-booster-2.19.10-1.fc37.noarch   @@System
    Upgraded jxl-pixbuf-loader-1:0.7.0-3.fc37.x86_64     @@System
    Upgraded libgpg-error-1.45-2.fc37.x86_64             @@System
    Upgraded libjxl-1:0.7.0-3.fc37.x86_64                @@System
    Upgraded libpcap-14:1.10.1-4.fc37.x86_64             @@System
    Upgraded libpwquality-1.4.4-11.fc37.x86_64           @@System
    Upgraded mesa-dri-drivers-22.3.1-1.fc37.x86_64       @@System
    Upgraded mesa-filesystem-22.3.1-1.fc37.x86_64        @@System
    Upgraded mesa-libEGL-22.3.1-1.fc37.x86_64            @@System
    Upgraded mesa-libGL-22.3.1-1.fc37.x86_64             @@System
    Upgraded mesa-libgbm-22.3.1-1.fc37.x86_64            @@System
    Upgraded mesa-libglapi-22.3.1-1.fc37.x86_64          @@System
    Upgraded mesa-libxatracker-22.3.1-1.fc37.x86_64      @@System
    Upgraded mesa-va-drivers-22.3.1-1.fc37.x86_64        @@System
    Upgraded mesa-vulkan-drivers-22.3.1-1.fc37.x86_64    @@System
    Upgraded mkpasswd-5.5.14-1.fc37.x86_64               @@System
    Upgraded ncurses-6.3-3.20220501.fc37.x86_64          @@System
    Upgraded ncurses-base-6.3-3.20220501.fc37.noarch     @@System
    Upgraded ncurses-libs-6.3-3.20220501.fc37.x86_64     @@System
    Upgraded net-tools-2.0-0.63.20160912git.fc37.x86_64  @@System
    Upgraded open-vm-tools-12.1.0-1.fc37.x86_64          @@System
    Upgraded open-vm-tools-desktop-12.1.0-1.fc37.x86_64  @@System
    Upgraded python3-pwquality-1.4.4-11.fc37.x86_64      @@System
    Upgraded python3-unbound-1.16.3-3.fc37.x86_64        @@System
    Upgraded tcpdump-14:4.99.1-7.fc37.x86_64             @@System
    Upgraded tpm2-tss-3.2.0-3.fc37.x86_64                @@System
    Upgraded unbound-anchor-1.16.3-3.fc37.x86_64         @@System
    Upgraded unbound-libs-1.16.3-3.fc37.x86_64           @@System
    Upgraded whois-5.5.14-1.fc37.x86_64                  @@System
    Upgraded whois-nls-5.5.14-1.fc37.noarch              @@System

Booting to fallback kernel fixed it for me. The 6.0.16-200.fc36.x86_64 is what breaks it for me. 6.0.15 still works. I didn’t touch Samba at all.

1 Like

That’s good to hear. I’ll try to figure out how to do that today when I get a chance. Thanks!

That answer can be found here.

After booting back into kernel 6.0.15 via the Grub menu, I removed all traces of 6.0.16 with the following command:
sudo dnf remove $(rpm -qa | grep ^kernel | grep 16)

Then, to ensure the system doesn’t try and reinstall, I blacklisted the 6.0.16 kernel packages by adding the following line to /etc/dnf/dnf.conf. This will be slightly different if you’re running FC37. I think the files are -300.fc37, so double-check if you’re going to do this.

# Bad packages
1 Like

By default a system that does not dual boot hides the grub menu. The menu can be seen by pressing the shift key during boot and the grub menu should show to allow selecting an older kernel.
It also can be set to display always with sudo grub2-editenv - unset menu_auto_hide

1 Like

Thanks. I’ll give that a try. I was able to use the

grubby --set-default /boot/vmxxxx

That allowed me to boot into 6.0.15 and I can use my samba share.

Edit: I can see my grub boot menu now. Thanks! @computersavvy

I proposed to common issues … see what they tell us.

1 Like

I have the same exact issue on a fresh install of F37 and on a second install which was upgraded from f36 to f37. Attempting to access any samba share will hardlock the sytem and I have to power the sytem off. I completely removed the systemd automount entries for the two target samba shares in /etc/fstab, rebooted and attempted to manually mount the samba shares to see if I would get a reportable error.

I did the following as root:

mount.cifs -o username=semanis // /mnt/backups

And was prompted for the samba password. After entering the password, the system hard locks such that the mouse pointer and keyboard will not respond in any way. I waited 10 minutes but the system was well still hard locked up. Again, had to poweroff the system.

1 Like

For reference


Looks like it will hopefully get patched in the next kernel update.


Same issue here.
kernel 6.0.17-300 and still broken.

1 Like

Should be fixed by kernel 6.0.18:

Since the fix was so fast and available already (just needs to be pushed stable), I don’t think we need to document this in Common Issues.


Thank you! I can confirm that mounting smb shares is possible again with kernel 6.0.18.

System info: Fedora Workstation 37, running in a VirtualBox VM in Windows 10 on Intel i5-4690.


Just updated and yes 6.0.18 so far is working with no crashes

1 Like