Slowing internet access

Originally worked with Fedora 36 and all was fine. Then finding internet sites eg. took over 5 minutes to load. I decided to upgrade to Fedora 37. Everything worked fine, speeds were good. Then one day it changed back to taking 5 minutes to load any site such as Once loaded it was fast moving around the site. It is like a DNS problem but another computer on the same net with a different OS works fine all the time. Not sure why upgrading cleared issue for a while, but it did. Accessing net from command line just as slow. I need to find a solution to this.

Does it only happen with the initial DNS request, or do the slowdowns occur at all while navigating around a site / using a web app?

Is this over Wi-Fi? For what it’s worth, I’ve needed to turn off Wi-Fi Powersave on my laptop to ensure a solid connection:

Wifi is turned off, I am using a wired connection, this is not a laptop. It is only happening on the initial DNS request. Once there, navigating is normal.