New install 33 workstation Firefox unusable slow, Chromium fine?

Hi all, fresh install of workstation 3.3 and have a intermittent very slow issue with Firefox and GNOME Web. Chromium is fine.

So far I have run dnf update with no improvement.

At a loss to where to start looking.

Thanks for any ideas, Dale

Can you elaborate on what is slow? Page loading, or specific pages? Or transfer speeds? Do they slow down the whole system?


Mostly noticed it trying to run searches, DDG, Yahoo, unusable on FF but fine on Chromium.

The computer is hard wired and speed tests show 90 Mbps or more, system monitor shows a light load and little network activity.

Can try direct loading of some web pages to see it might be just a search issue.

Just tried direct loading and another speed test using FF and it’s crazy fast now. Very strange - and it’s not just FF. Evolution took about 10 mins to return a password request on a new account setup. dnf took 5 min or so to install htop. It’s not just today, the issue spans days, fresh install 1-14 and update this morning 1-16

Each time I run a speed test it’s above 90Mbps.

Maybe I just need to wait a few days and see, perhaps my ISP is a bit wonky.

Hmmm, yeah. Take a look at about:performance in Firefox to help diagnose what’s slowing things down. Or look at the Inspector, from the Tools | Web Developer menu.


Update, it was acting up again this morning. Decided to take a break and switch the monitor (one monitor - two computers) back to my Debian Buster box and ran another speed test that came up very fast so I think the problem is not with my ISP but has something to do with the networking/hardware on the other computer that I installed fedora on. When I get some time I will research network hardware trouble shooting and try to come up with some tests to try and sort this out.

Think I have sorted it out. Ran some CLI commands and found I could ping an IP but not the domain. This made me want to look at the DNS settings. I ran sudo resolvectl status but unfortunately I did not think to save the results but the best I can remember is the DNS came back as Current DNS Servers:

Then I changed the advance settings in my router: was get automatically from ISP to use these DNS servers and changed the primary.
Now when I run sudo resolvectl status I see the DNS I entered in the router.
[dkc@localhost ~]$ !187
sudo resolvectl status
Protocols: LLMNR=resolve -mDNS -DNSOverTLS DNSSEC=no/unsupported
resolv.conf mode: stub

Link 2 (enp1s0)
Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server:
DNS Servers:
DNS Domain: ~.

It is working fine now, best guess is either the DNS server that was assigned automatically was wonky or my install of Fedora did not like the previous router settings.

If it acts up again I think I will set a static IP and set the DNS. Found a good link on how to do this:

1 Like

I guess this is a new issue in bugzilla: 1913390 – Firefox takes a very long time to start - freezes on systemd-resolv.
In journalctl -b --user something related to DBus can be discovered:

gnome-shell[4393]: Received error from D-Bus search provider firefox.desktop: Gio.DBusError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable

dnf took 5 min or so to install htop

If you’re talking about download speed, dnf may use incorrect mirrors to download pacakges (by default, fedora use metalink to give dnf mirrors according to your ip address, unlike other distro; I once find it trying to connect to really far away onces, even timed out after 30 seconds). You can try sudo dnf clean all to clean caches and make sudo dnf makecache to force dnf make its cache again, and (hopefully) dnf will pickup faster mirrors again.
Alternatively, you can setup mirrors manually. Edit repos in /etc/yum.repos.d/*, comment out metalink= , and fill in mirrors you find in baseurl= (either search by a search engine or manually find one in, normally you want to edit fedora.repo fedora-modular.repo fedora-updates.repo fedora-updates-modular.repo (edit further rpmfusion repos if you enabled rpmfusion).

Very strange - and it’s not just FF. Evolution took about 10 mins to return a password request on a new account setup

If it’s ff, gnome web, evolution and not everything (unlike the case in After Fedora 33 update; kworker/u32:2+events _unbound killing my cpu - #15 by huscape where everything is crazily slow), then it may all due to the #1913390 redhat bugzilla.

Thanks for the info, will keep it in mind if I have any more trouble. In my case I think it was simply a wonky DNS setting or server. What through me off track was Chromium was working fine. Perhaps it shares enough with Chrome that all the sites and searches I did had already been cached or something like that. Live and learn, next time I will jump right into running some CLI commands and double check the network status.