Network very Slow

Hello! I’m having some weird problems with my network in Fedora 36 (wifi and ethernet), it’s very slow, the entire system, not only on browsers. I even don’t know how to debug this.

The problem seems something like DNS, it’s about 5 secounds to open a page, after it open the speed is fast. I test Ubuntu 22.04 lts and Windows 10, unfortunately this problem only occours in Fedora.

Whats is impacted with this issue:

  • Browsers
  • dnf
  • wget

*Everithing that depends on internet.

I try the Fedora 36 live (whitout install) and the problem is the same.

this is my hardware:

I got some kind of log, I don’t know if it can be useful:

I was experiencing similar issues, but only on Fedora. On any other distro, webpages would load just fine. What I did to fix it was to first disable IPv6 for my network connection. Then, I set DNS to use the addresses provided by my ISP, instead of my router. You can login to the admin portal for your router to find these addresses.

Hello @mrsudowoodo ! thank you for the reply, I tried this steps, but doesn’t resolve my issue unfortunately.

I think it’s a problem with systemd-resolved, the resolvectl query command took 5 seconds.

I following this documentation to Disabling DNS processing in the NetworkManager configuration:

and for now my network is fine, I’m still testing.


That is very good to know. I’ll be giving that a try the next time I’m running Fedora. Thank you for posting what worked for you!

Even disabling the DNS processing, I still have some problems.
I buy a Mikrotik HAP mini (USD 19) e put it after my ISP modem, then I put my tp-link (AX1500) on the MikroTik (with access point mode), and now everything is perfect.

I don’t know if it’s a problem with the tp-link or my ISP (or both). I also use MikroTik to login into my ISP provider (PPPoE).

I spent many hours over the past 2 weeks trying to figure out recent slowness that has been happening on my Fdora 36 system, web pages and system was really wonky all and all. It’s dual boot system and the Windows 10 did not exhibit the samm sysmptoms which really was stumopnng me. Disabling ipv6 that is what finally worked for me.

Here is a summary of the steps .

  1. Append to /etc/sysctl.conf
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1

  2. Load the above file
    sysctl -p

  3. Check. A ‘1’ means IPv6 has been disabled
    cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Hope the above helps someone else in figuring this out.

Thaaanks, it works like a charm for me ^^