My slow realtek 8821CE, cannot even open some pages

On fedora 38,

Tired, I searched several topics and but no effect. I even see some sites and forums not working or reachable or slow load. I don’t know what info to tell you so you can help me.

Try to disable Wi-Fi power saving:
How to keep internet connection connected without interruption - #4 by vgaetera

Also specify a public DNS like or and disable local DNS in the connection settings.

Don’t now for certain, but yup that makes it stable and high speed. Thanks!

EDITS: what more tags and edits should I perform to help people pinpointing this kind of issue.