[Silverblue] wineasio & wineasio-pipewire for Silverblue / rpm-ostree?

Hello everyone,

I’m a noob at Linux, and an extended noob at Silverblue, so please bear with me. I liked the concept of Silverblue, so decided to use it as my main daily driver.

So far everything works great. As I’m doing some audio work, I’d like to use wineasio. Now, PipeWire is already preinstalled on Silverblue, which is great. However, when I try to install wineasio or wineasio-pipewire through rpm-ostree, it says there’s no such package. But here (patrickl/pipewire-wineasio Copr) the man explains how to install this package on Workstation by using simple dnf command.

My understanding is that Silverblue uses rpm-ostree command when I want to layer packages in the OS tree, so I simply replace dnf install with rpm-ostree install. However, the package is not there.

Am I doing something wrong? Also, would you recommend against installing wineasio and/or wineasio-pipewire on my system?

Regards,

  • A

Reading GitHub - wineasio/wineasio: ASIO to JACK driver for WINE, I think you probably should try to install all of that into a toolbox where you can easily install coprs and wine.

Dear Timothee, thanks for your reply.

I already have FL Studio installed inside Bottles (Flatpak). My question would be, if I install wineasio in a toolbox, would it be recognised and work with Flatpaks and the system audio driver (pipewire)? Or would it be isolated and practically unusable?

Thanks,

  • A

EDIT:

  1. tried to install this copr (patrickl/wine-testing Copr). However, it says there’s no wine there, which makes sense as it is an isolated toolbox. However, if I install wine in the toolbox, it will use that instead of my real system’s, and my assumption is it will not work (or at least won’t work for Flatpaks I run in the regular environment).
  2. trying to compile wineasio with ‘make 64’, however it complains there isn’t jack available. Again, the same logic as above. Oh boy.

I think copr doesn’t work because it relies on some sort of dnf extension which is probably just not implemented yet.

https://docs.fedoraproject.org/en-US/neurofedora/copr/

Actually, it seems like it might be.

The issue mentioned in that thread has been implemented, though I’m not entirely sure it’s what you need, and if it’s still available, I’d check the rpm-ostree manual. Can’t really do that myself right now.

Alternatively, if that doesn’t work have you tried manually install the rpm? You can just use rpm-ostree install rpm. It might be a pain to get all dependencies though.

If you have FL Studio inside Bottles then you need to install wineasio inside your bottle and pipewire-wineasio on the host and make sure that Flatpak gives access to it (I don’t know how asio works).

You can install packages from a Copr by downloading the repo file into /etc/yum.repos.d and then rpm-ostree install pkg.