Silverblue issue/bug reporting location

https://pagure.io/teamsilverblue
or
https://pagure.io/fedora-silverblue

This:
https://silverblue.fedoraproject.org/contribute
points to the 2nd one. Both are being used, and the first one claims itself as the bugreporter, where the second one doens’t describe itself at all.

Can it be made more clear what their respective purposes are?

3 Likes

It would appear there are two separate bug trackers, maybe @sanja can shed some light. I would recommend using the first one listed for filing bugs in the interim. I believe the second one was possibly the initial creation when SB was maybe not going to fly.

We need to delete the Pagure ones and use the one on GitHub. But the issues need to be migrated which is why all 3 are currently still in place and open. I’ve probably communicated this before but not put it on the website. The one with the biggest count of issues is the one currently in use (teamsilverblue).

I could just go ahead and delete the other one but didn’t want the issues to go missing. If someone can take the time to migrate them over even if it means re-creating, then that’s fine with me. This happened because there is no option to rename things in Pagure, so we created the other one but couldn’t migrate the issues from the first one (teamsilverblue).

2 Likes

I can take that on. I’ll see if any are duplicates first then go from there. I have GitHub access correct?

4 Likes

Thanks, that would be perfect! It’s quite some work, though.

Yes, you should have full access: https://github.com/fedora-silverblue/issue-tracker/issues

I have put in a PR on the site github repo - changing the link to point to the github repo rather than Pagure

1 Like

So I guess there is still the migration problem even with someone volunteering to help the migration (being me). :thinking: Most of this will require manual intervention I am thinking.

Yes which is why I haven’t done it yet. If you find a best way to migrate the issues, let me know. :wink:

If cloning would also clone the issues, it would be simple I think. Apparently when a repo is created on Pagure, there are actually four created as per Pagure …

  • A git repository containing the source code, displayed in the main section of the pagure project.
    
  • A git repository for the documentation
    
  • A git repository for the issues and their metadata
    
  • A git repository for the metadata for pull-requests
    

So, if these can be accessed with the following caveat…
" You can find the URLs to access or clone these git repositories on the overview page of the project. On the top right of the page, in the drop-down menu entitled Clone . Beware that if documentation, the issue tracker or the pull-requests are disabled on the project, the corresponding URL will not be shown."
So, I can’t see them when I do a clone from the pull down menu, just get the source code option. Is there any way to enable those to be accessed? It must be a site admin thing.

1 Like

Git URL for the fedora-silverblue Pagure issues:

ssh://git@pagure.io/tickets/fedora-silverblue.git

Git URL for the teamsilverblue Pagure issues:

ssh://git@pagure.io/tickets/teamsilverblue.git

2 Likes

I guess that you have done this already since I can’t clone the repos (they don’t exist is the message).

I haven’t done anything migration-wise as I think it’s going to be a lot of work and communication required. Or just manually copying and losing the original issue author unless they do it themselves. Automation would be a fabulous but still losing the author I guess.

The issues definitely exist still on Pagure. :thinking:

The first day you posted the links above I tried it and was getting the same error which I assumed then was my ssh setup and my local git settings that were the problem. Everything seems okay, but I am getting this message
`git clone ssh://git@pagure.io/tickets/teamsilverblue.git
Cloning into ‘teamsilverblue’…
warning: templates not found in /home/ssnow/.git_templates
No such repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.`
Which I think can still be ssh related. Any ideas?
Aside from that, like you said it is a bit messy just copying things over like that manually, and time consuming for sure.

I was able to get it working:

$ git clone ssh://git@pagure.io/tickets/fedora-silverblue.git
Cloning into 'fedora-silverblue'...
remote: Counting objects: 242, done.
remote: Compressing objects: 100% (242/242), done.
remote: Total 242 (delta 142), reused 3 (delta 0)
Receiving objects: 100% (242/242), 308.84 KiB | 675.00 KiB/s, done.
Resolving deltas: 100% (142/142), done.

Make sure your SSH key is uploaded to your user profile as noted here - https://docs.pagure.org/pagure/usage/first_steps.html#upload-your-ssh-key

That’d be my first guess; if that doesn’t work…we can try something else.

Oops, I mis-read the previous message was able the teamsilverblue repo. I can’t seem to clone the issues for that repo either:

$ git clone ssh://git@pagure.io/tickets/teamsilverblue.git
Cloning into 'teamsilverblue'...
No such repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Looking at the overview of that repo, there are no additional repos listed for the issues or PRs like the fedora-silverblue repo has. Probably a config issue on the repo?

I made you both admin on that repo now. You should be able to make any changes you need plus maybe it just works now.

1 Like

Hi @miabbott thanks for your suggestion. I had been (awhile back) playing around with my dot files and used jlebons .gitconfig file. I had the name set to my real name instead of the username for pagure. I can clone teamsilverblue now, I’ll try the other one next.
I can clone teamsilverblue issues but not fedora-silverblue issues.

Thank you @sanja, I had my real name instead of my pagure.io username in my .gitconfig file. But the admin rights were also likely needed.
I still can’t clone the fedora-silverblue issues though.

1 Like

Thanks @sanja. I can clone both repos now and just pushed them to GH for mirroring purposes.

Anyone else should be able to clone them from GH, if they like.

@jakfrost Let me know if this works for you

1 Like

Awesome, thanks for the great work!