Selecting handsfree for a bluetooth headset makes sound not working

When I attach a bluetooth headset and select Handsfree in Sound options, I click Test, and only noise plays.

I have tried 2 different bluetooth headsets with the same result. The headsets are Airpods v2 and NERO-TX.

I am running kernel 6.4.15-200.fc38.x86_64 on a Dell Inc. XPS 9320.

When I select Headphone, it swithces Input to built-in microphone. If I select Handsfree in Input now, it swithces Output to Handsfree (where sound is not working).

What happens if you reduce the input volume to minimal. ?

In my experience I use only the lowest acceptable input volume. Having the input volume at max often causes problems.

The problem is the output volume, not the input volume. The output (bluetooth headset) just plays noise, when Handsfree (and not Headphone) is selected.

If I wan’t to use the microphone, the sound output is forced to Handsfree (where sound is not working).

Somewhat related to Sound is Dummy output when booting Fedora 38 with kernel 6.5.5

Understood, but if you have an active mic with the input volume maxed out (as it appears you have) then it will have both input and output active. Thus unwanted noise, possibly even feedback.

It would at least be worth a try at reducing the input volume to see if that has any affect.

Actually, the noise is only playing for a couple of seconds. Tomorrow European time I will have to it, if the headset works anyway.

Lowering the input volume did not help, when running a simple test, using the “Test Speakers” window.

I still wonder that when I select the Handsfree option, the output is only mono (only one speaker is available in the “Test Speakers” window).