Segmentations Faults everywhere

fedora starting to throw many segmentation fault errors.

i can’t use any application, i can use application until segmentation fault, after this application is fully broken and can’t be started because it throw segmentation fault the only way to fix is reinstall it.

the problem is dnf was now in segmentation fault and i can’t do anything to fix it.
[1] 3497 segmentation fault (core dumped) dnf

and it’s seems that many application that use .sh is high-risk to this segfaults. Electron applications or any other application that dont use .sh for some functions work normarly.

I think this points to a hardware problem — possibly RAM, especially because it seems to happen with high-memory-use applications like those based on Electron.

i tried running memtest it did not found any errors at all, it’s seems that only some packages segfaults. Things like flatpak can run without any errors.

also it’s not looks like hardware issue because same command fail even after reboot.

i tried coredumpctl gdb on dnf here is output:

BFD: warning: /usr/lib64/python3.11/site-packages/hawkey/ has a corrupt string table index                                                         
[New LWP 15738]
BFD: warning: /usr/lib64/python3.11/site-packages/hawkey/ has a corrupt string table index

[Thread debugging using libthread_db enabled]                                                                                                                
Using host libthread_db library "/lib64/".
--Type <RET> for more, q to quit, c to continue without paging--
Core was generated by `/usr/bin/python3 /usr/bin/dnf'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  elf_dynamic_do_Rela (skip_ifunc=33554432, lazy=0, nrelative=0, relsize=0, reladdr=0, scope=<optimized out>, map=0x557eee4c0940)
    at /usr/src/debug/glibc-2.37-4.fc38.x86_64/elf/do-rel.h:52
52	 const ElfW(Sym) *const symtab               

here is backtrace

seems to be releated to what is that?

i fixed it. for some reason file is corrupted i repaired it now everything works.

How did you repair it?
Reinstall hawkey? Remove then reinstall hawkey? or something else?

Future readers with similar problems may wish to know how that was done.