Second monitor randomly stops working

Hi, I have a problem with my second monitor. My second monitor worked perfectly. Until a kernel update (not the last one, but the one before the last one). From that point my second monitor works and don’t works randomly how it feels (I have no idea why it starts or stops working). Fedora has a problem detecting it as a output device. The problem is not in my monitor, on Win11 and PopOS worked fine. I tried reinstalling my nvidia drivers. Reinstalled whole FedoraOS, didn’t help. After a reboot there is a chance that it magically start detecting the monitor.
Fedora 40 xfce spin x11
I have NVIDIA GeForce RTX 3070-ti mobile
Drivers version 550.90.07
Also I have an integrated GPU in Intel i7-12700H
The second monitor is an older LG television that I’m using for few years as a second monitor, but as I said, on other OSes it works fine.
I’ll be glad for any type of help.

Please post the output of both dnf list installed \*nvidia\* and inxi -Fzxx by copying and pasting using the preformatted text button </> on the text window toolbar. That may give us enough info to assist.

dnf list installed \*nvidia\*

akmod-nvidia.x86_64                                  3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
kmod-nvidia-6.9.5-200.fc40.x86_64.x86_64             3:550.90.07-1.fc40             @@commandline             
kmod-nvidia-6.9.6-200.fc40.x86_64.x86_64             3:550.90.07-1.fc40             @@commandline             
nvidia-gpu-firmware.noarch                           20240610-1.fc40                @updates                  
nvidia-modprobe.x86_64                               3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                           3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
nvidia-settings.x86_64                               3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                           3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                      3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                   3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                 3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                   3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                        3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                      3:550.90.07-1.fc40             @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                     3:550.90.07-1.fc40             @rpmfusion-nonfree-updates

and inxi -Fzxx

System:
  Kernel: 6.9.6-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.41 wm: xfwm4 dm: LightDM
    Distro: Fedora Linux 40 (Xfce)
Machine:
  Type: Laptop System: LENOVO product: 82RF v: Legion 5 Pro 16IAH7H
    serial: <superuser required> Chassis: type: 10 v: Legion 5 Pro 16IAH7H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN
    serial: <superuser required> part-nu: LENOVO_MT_82RF_BU_idea_FM_Legion 5
    Pro 16IAH7H UEFI: LENOVO v: J2CN56WW date: 09/18/2023
Battery:
  ID-1: BAT0 charge: 79.1 Wh (97.1%) condition: 81.5/80.0 Wh (101.9%)
    volts: 16.5 min: 15.4 model: Celxpert L21C4PC1 serial: <filter>
    status: not charging
CPU:
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.2 MiB L2: 11.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 695 high: 1340 min/max: 400/4600:4700:3500 cores:
    1: 1113 2: 1340 3: 400 4: 400 5: 400 6: 1272 7: 855 8: 1174 9: 1164 10: 400
    11: 400 12: 800 13: 900 14: 400 15: 400 16: 400 17: 400 18: 897 19: 400
    20: 400 bogomips: 107520
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.2 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6
  Device-2: NVIDIA GA104M [Geforce RTX 3070 Ti Laptop GPU] vendor: Lenovo
    driver: nvidia v: 550.90.07 arch: Ampere bus-ID: 0000:01:00.0
    chip-ID: 10de:24e0
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: xfwm4 v: 4.18.0 driver: X: loaded: modesetting
    unloaded: fbdev,vesa dri: iris gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 2048x1280 s-dpi: 96
  Monitor-1: eDP-1 model-id: CSO 0x1612 res: 2048x1280 dpi: 151
    diag: 407mm (16")
  API: OpenGL v: 4.6 vendor: intel mesa v: 24.1.2 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
    device-ID: 8086:46a6
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8
  Device-2: NVIDIA GA104 High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228b
  Device-3: Creative Sound Blaster X-Fi Go! Pro
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 bus-ID: 3-2.1.1:6 chip-ID: 041e:3233
  API: ALSA v: k6.9.6-200.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0
  IF: wlp0s20f3 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 0000:32:00.0
    chip-ID: 10ec:8168
  IF: enp50s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-10:5 chip-ID: 8087:0033
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:467f
Drives:
  Local Storage: total: 2.3 TiB used: 274.78 GiB (11.7%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDKBA1T0TFH size: 953.87 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 51.9 C
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 40.9 C
  ID-3: /dev/sda vendor: Seagate model: ST500DM009-2F110A size: 465.76 GiB
    type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 serial: <filter>
Partition:
  ID-1: / size: 1019.44 GiB used: 274.25 GiB (26.9%) fs: btrfs dev: /dev/dm-0
    mapped: luks-9c3de6c4-c042-44e7-b0d7-4d4997b36fd6
  ID-2: /boot size: 973.4 MiB used: 466 MiB (47.9%) fs: ext4
    dev: /dev/nvme0n1p5
  ID-3: /boot/efi size: 258.5 MiB used: 78.7 MiB (30.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 1019.44 GiB used: 274.25 GiB (26.9%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-9c3de6c4-c042-44e7-b0d7-4d4997b36fd6
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.34 GiB used: 3.38 GiB (22.0%)
  Processes: 950 Power: uptime: 11h 29m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 19 Compilers: clang: 17 gcc: 14.1.1
    Shell: Bash v: 5.2.26 running-in: xfce4-terminal inxi: 3.3.34

Now my second monitor didn’t worked for a weak. Still an issue.

The 555.58.02 driver was released by rpmfusion on Friday. Upgrade that and it should start working again.

Added f40, kernel, x11, xfce

It doesn’t work with upgraded nvidia drivers. Also It no longer works from time to time. It used to work for like 1 or 2 restarts (Like after a restart there was like a 10 % chance that the second monitor’d work (sounds weird but well It worked that way)). Now it won’t work no matter what, but on my dual boot Win11 the second monitor still works without issues.
But thank you for some sort of help.

There’s been a bug with Nvidia GPU’s and a second monitor recently. Could you try to, unplug the second monitor, then shutdown and plug back the monitor, and then boot up the machines.

I tried it multiple times, it didn’t help, but thank you for some help.