Fedora 36 KDE, nvidia, second monitor stops working after login

I’m using Fedora 36 KDE with an NVIDIA gpu, I have 2 monitors and they were working fine.

However, I left my computer for a while and it went to sleep and when it woke up only 1 monitor works, my secondary one.

If I unplug the monitor that is working then it switches to the other monitor but as soon as I plug the other monitor back in it switches to that one.

I tried rebooting my pc and both monitors were working correctly, but right after I typed my password on the login screen the issue came back and my primary monitor turned off and I’m only left with the secondary one.

Both monitors are detected by the system though, I was able to re-enable my primary monitor from the settings, I had to check the ‘enabled’ box and then give it a resolution, refresh rate, position, add my panels again, etc.

After that if my pc goes to sleep from inactivity then as it wakes up again the primary monitor is once again turned off, but the system seems to think that it’s still on or something, all I have to do is enable it and all of my windows will still be there where I left them.

After that if I once again turn my computer off, when it turns back on I’m back to square one with the monitor being off, fedora treating it like I only have 1 monitor, and me having to redo everything.

I followed RPMFusion’s guide to remove their drivers with sudo dnf remove xorg-x11-drv-nvidia\*
and I also followed their ‘Recover from NVIDIA installer’ section with these commands

sudo rm -f /usr/lib{,64}/libGL.so.* /usr/lib{,64}/libEGL.so.*
sudo rm -f /usr/lib{,64}/xorg/modules/extensions/libglx.so
sudo dnf reinstall xorg-x11-server-Xorg mesa-libGL mesa-libEGL libglvnd\*
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.saved

I then booted with nouveau and everything worked fine, but as soon as I reinstalled the RPMFusion drivers then the problem came back

I don’t even know what commands to use to debug this

We need to know a bit more about your computer, post here output of inxi -SMGaz. Also run dmesg -W in Konsole before putting the PC to sleep and post here it’s output after waking it up.