Second Monitor Not Found - Fedora 38 - NVIDIA RTX 4070 GPU

I just installed Fedora 38 (dual boot with Windows) on a SAGER notebook with NVIDIA GeForce RTX 4070. I’m trying to connect to a second monitor, but it doesn’t show up at all (works perfectly on Windows).

Could I get some help? What information should I grab?

Do you have the nvidia drivers installed from the rpmfusion repo? If not then that should be your first goal.

Enable the “third party repos” within the gnome software app, then from the command line install the drivers with sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda. Wait 5 minutes then reboot and (as long as secure boot is disabled) the drivers should load.

Let us see the results of dnf list installed '*nvidia*'

I installed those drivers and the monitor shows up, but I have the same problems with resolution refresh that I had here (also have dual GPU again). I followed the steps in listed in this article that worked then, but that didn’t fix it.

I also made sure secure boot is turned off.

Any idea what I’m missing?

dnf list installed '*nvidia*'

Installed Packages
akmod-nvidia.x86_64                         3:535.54.03-1.fc38    @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.3.12-200.fc38.x86_64.x86_64   3:535.54.03-1.fc38    @@commandline                   
nvidia-gpu-firmware.noarch                  20230625-151.fc38     @updates                        
nvidia-persistenced.x86_64                  3:535.54.03-1.fc38    @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                      3:535.54.03-1.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                  3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64             3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.i686          3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64        3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64          3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686               3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64             3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64            3:535.54.03-2.fc38    @rpmfusion-nonfree-nvidia-driver

inxi -CMGxxS --edid

  Host: anubis Kernel: 6.3.12-200.fc38.x86_64 arch: x86_64 bits: 64
    compiler: gcc v: 2.39-9.fc38
    parameters: BOOT_IMAGE=(hd1,gpt2)/vmlinuz-6.3.12-200.fc38.x86_64
    root=UUID=5c8dfa50-7793-4e6e-ae11-9fb1e26af859 ro rootflags=subvol=root
    rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
  Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Fedora release 38 (Thirty Eight)
  Type: Laptop System: Notebook product: PE60RNE_RND_RNC v: N/A
    serial: <superuser required> Chassis: No Enclosure type: 10
    serial: <superuser required>
  Mobo: Notebook model: PE60RNE_RND_RNC serial: <superuser required>
    UEFI: INSYDE v: 1.07.05LS1 date: 04/13/2023
  Info: model: 13th Gen Intel Core i9-13900H bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
    microcode: 0x4112
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 2871 high: 3000 min/max: 400/5200:5400:4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3000 2: 3000 3: 3000
    4: 3000 5: 3000 6: 3000 7: 2176 8: 3000 9: 3000 10: 3000 11: 3000 12: 3000
    13: 3000 14: 1247 15: 3000 16: 3000 17: 3000 18: 3000 19: 3000 20: 3000
    bogomips: 119807
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: CLEVO/KAPOK
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 0000:00:02.0
    chip-ID: 8086:a7a0 class-ID: 0300
  Device-2: NVIDIA AD106M [GeForce RTX 4070 Max-Q / Mobile]
    vendor: CLEVO/KAPOK driver: nvidia v: 535.54.03
    alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022-23+ ports: active: none off: HDMI-A-1
    empty: DP-5,eDP-2 bus-ID: 0000:01:00.0 chip-ID: 10de:2860 class-ID: 0300
  Device-3: Chicony USB2.0 Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-8:3 chip-ID: 04f2:b7c3
    class-ID: fe01 serial: 01.00.00
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: gpu: i915,nvidia,nvidia-nvswitch
    display-ID: 0
  Monitor-1: HDMI-A-1 model: 43S425 built: 2020 res: 3840x2160 dpi: 103
    gamma: 1.2 chroma: red: x: 0.643 y: 0.333 green: x: 0.322 y: 0.624 blue:
    x: 0.145 y: 0.055 white: x: 0.278 y: 0.290 size: 800x450mm (31.5x17.72")
    diag: 1093mm (43") ratio: 16:9 modes: 3840x2160, 4096x2160, 1920x1080,
    1680x1050, 1280x1024, 1440x900, 1280x960, 1280x800, 1152x864, 1280x720,
    1024x768, 800x600, 720x480, 640x480
  EDID-Warnings: 1: parse_edid: unhandled CEA mode 95 2: parse_edid:
    unhandled CEA mode 93 3: parse_edid: unhandled CEA mode 100 4: parse_edid:
    unhandled CEA mode 98
  Monitor-2: eDP-1 model: BOE Display 0x0af0 built: 2021 res: 2560x1600
    dpi: 189 gamma: 1.2 chroma: red: x: 0.647 y: 0.325 green: x: 0.290 y: 0.620
    blue: x: 0.149 y: 0.059 white: x: 0.314 y: 0.329
    size: 344x215mm (13.54x8.46") diag: 406mm (16") ratio: 16:10
    modes: 2560x1600
  EDID-Warnings: 1: parse_edid: unknown tag 112
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel Graphics (RPL-P)
    direct-render: Yes

dmesg | grep -iE 'secure|nvidia'

[    0.000000] secureboot: Secure boot disabled
[    0.008406] secureboot: Secure boot disabled
[    1.471406] integrity: Loaded X.509 cert 'Secure Certificate: 01dcc89619884ca147983429f8a4a1a0'
[    2.582156] sdhci: Secure Digital Host Controller Interface driver
[    6.408471] Bluetooth: hci0: Secure boot is enabled
[    6.494462] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input18
[    6.494608] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input19
[    6.494751] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input20
[    6.494785] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input21
[    7.528198] nvidia: loading out-of-tree module taints kernel.
[    7.528206] nvidia: module license 'NVIDIA' taints kernel.
[    7.536759] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    7.647747] nvidia-nvlink: Nvlink Core is being initialized, major device number 510
[    7.648218] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    7.648312] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    7.695844] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  535.54.03  Tue Jun  6 22:20:39 UTC 2023
[    7.762194] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[    7.823875] nvidia-uvm: Loaded the UVM driver, major device number 508.
[    7.880353] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  535.54.03  Tue Jun  6 22:17:39 UTC 2023
[    7.883892] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    9.387522] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device DP-2
[    9.396589] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device DP-2
[    9.624934] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[   17.200245] [drm] [nvidia-drm] [GPU ID 0x00000100] Framebuffer memory not appropriate for scanout
[   17.200248] [drm] [nvidia-drm] [GPU ID 0x00000100] Framebuffer memory not appropriate for scanout
[   30.837294] [drm] [nvidia-drm] [GPU ID 0x00000100] Framebuffer memory not appropriate for scanout
[   30.837299] [drm] [nvidia-drm] [GPU ID 0x00000100] Framebuffer memory not appropriate for scanout

cat /etc/X11/xorg.conf.d/nvidia.conf

#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
	Option "PrimaryGPU" "yes"

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
	Option "PrimaryGPU" "yes"

It looks like you have followed every step we discussed and that worked with the older laptop and the nvidia 2070 GPU.

What is the kernel command line.?
Normally that would be shown in the dmesg output you show, (both before and after the 2 secure boot lines) but it can also be gotten with cat /proc/cmdline as well

Additionally in the dmesg output I see the warnings at ~9 seconds about nvidia-modeset and failure to read EDID. How is the monitor attached? – directly to the machine or via a docking station? If there is a docking station involved try without it and connect the monitor directly to the laptop.

I didn’t follow the steps from last time to sign the modules, but I assumed that was just to let me turn secure boot on. Is that right? Or should I go back and do those and then re-do the other steps?

cat /proc/cmdline

BOOT_IMAGE=(hd1,gpt2)/vmlinuz-6.3.12-200.fc38.x86_64 root=UUID=5c8dfa50-7793-4e6e-ae11-9fb1e26af859 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau

Yeah, I noticed the EDID error, but wasn’t sure what to make of it. The monitor is attached directly to the machine.

I don’t know that particular laptop but it seems on some systems that more kernel command line options may be required. Recently there were a couple of users who reported their system displayed duplicate (ghost) monitors in the gnome settings and the monitors did not appear to function properly. The extra options seem to have worked for them and may work for you as well.

My system has this for command line options that seem directly related to the nvidia card.
rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init

When booting you can press and hold the shift key when first booting, (just after the bios prompt disappears), and it should then display the grub menu. At that point, pressing the e key to edit the entries for the kernel to be booted will allow one to add those options into the line that begins with linux for temporary testing purposes just to see if they might make a difference.

Adding them in one at a time (or both) allows evaluating the effect, and if it solves the issue then the change can be made permanent for future use.

Additionally, there is actually a newer driver in testing at rpmfusion for nvidia that might be useful as well. The 535.86.05 driver is being tested there. So far I am using it and it seems good here.

There doesn’t seem to be any change when running those grub command line options.

How would I install the new driver?

It can be gotten with sudo dnf upgrade '*nvidia*' --enablerepo rpmfusion-nonfree-updates-testing

That will update only the packages with nvidia in the name and enable that repo only for that one command instance.

If you have any problems with that driver please report it back as a bug to rpmfusion.

I get Error: Unknown repo: 'rpmfusion-nonfree-updates-testing' Do I need to enable that repo somehow?

Apparently you installed the drivers using the rpmfusion-nonfree-nvidia-driver repo which does not enable the rpmfusion-free and rpmfusion-nonfree repos.

Yes you need to enable the noted repos which can be done following the directions here

I tried installing the newer driver, but it didn’t help.

I’m at a loss. I’ve tried fresh installs of Fedora 38/37 a dozen times, then following these and other instructions and nothing works. The 4070 shows up under GPU in Screenfetch, but in response to glxinfo the built-in GPU shows up and under settings, they both show up. Any ideas what’s missing or what I should check?