Screen lock in Fedora Linux 39 workstation

Could really use some help here. I’ve installed Fedora Linux 39 on a Lenovo ThinkPad. I’ve had variants of Linux on the machine before. It is a very clean build, and yet screen locking is not working. This is critical because I use this for a work environment with locking policies.

Locking works just fine when performing manually via Super-L.

Here are my settings from dconf:

dconf read /org/gnome/desktop/session/idle-delay
uint32 60
dconf read /org/gnome/desktop/screensaver/lock-enabled
gsettings get org.gnome.desktop.lockdown disable-lock-screen

I’ve also written this scrpt which confrims that Gnome understands my usage is inactive:

while true; do       gdbus call --session --dest org.gnome.Mutter.IdleMonitor --object-path /org/gnome/Mutter/IdleMonitor/Core --method org.gnome.Mutter.IdleMonitor.GetIdletime; sleep 1; done

which outputs

(uint64 0,)
(uint64 1,)
(uint64 0,)
(uint64 3,)
(uint64 3,)
(uint64 292,)
(uint64 802,)
(uint64 1808,)
(uint64 2815,)
(uint64 3821,)
(uint64 4828,)
(uint64 62345,)
(uint64 65215,)

The number increases until I move the mouse again. However when it reaches the minute setting I’ve set, nothing happens.

I have disabled all extensions, and closed all apps during this test except the terminal.

I’m not sure how to debug this any further?

The gnome settings panel under privacy → screen blank sets the screen lock for Workstation. Have you looked there?