F39 Workstation "disable-lock-screen" not writable

The lock-screen is non functional due to the dconf key “disable-lock-screen” preset to
not writable and can not be modified as per follows:

$ gsettings get org.gnome.desktop.lockdown disable-lock-screen
$ true

$ gsettings set org.gnome.desktop.lockdown disable-lock-screen false
$ The key is not writable

Is there any way to set the key writable or any other way to get the screen lock working?


You probably need to undo this: Lock down specific settings

Check for a file in /etc/dconf/db/local.d/locks/.

1 Like

The dir /etc/dconf/db/local.d/locks/ is empty. No lockdowns have been defined yet.
This is a fresh F39 installation. It’s weird this key is not writable!

Can you change other settings? Maybe there’s a permission issue with the dconf database.

ls -l ~/.config/dconf/user

Do you see anything if you run gsettings with G_MESSAGES_DEBUG=all?

The other settings can be changed.

Here’s the gsettings run with the debug option:

$ G_MESSAGES_DEBUG=all gsettings set org.gnome.desktop.lockdown disable-lock-screen false
(process:112071): GLib-GIO-DEBUG: 07:55:13.772: _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
(process:112071): dconf-DEBUG: 07:55:13.772: watch_fast: “/org/gnome/desktop/lockdown/” (establishing: 0, active: 0)
(process:112071): dconf-DEBUG: 07:55:13.773: change_fast
The key is not writable

Found the cause!

In order to disable the gdm user-list, I placed some files in /etc/dconf/{db, profile}
and there was the following entry in those files:


Apparently, this had the side-effect of turning the “disable-lock-screen” key not writable!

Once, the file-db line was removed the key was writable.

No idea why adding this line caused the problem.


It sounds like you put that in the user profile, not gdm. Thus you applied GDM’s default settings and locks to your user session.


If you can confirm that it happens when following that guide exactly, I can take another look.

Yes, the problem was with the user profile. Reset the modified file
/etc/dconf/profile/user to its original and then followed the guide
on the posted link and it’s all good now!