Rpm-ostree update fails with 'dbus-owner changed' - not libsolv problem

Hi I have been getting the issue where the command rpm-ostree craps out with the message ‘dbus owner changed’. I don’t beleive this issue is to do with libsolv or nvidia updates.

I have just started getting this issue with my main silverblue installation, having had it with a raspberry pi before, which was libsolv issue.

I have tried a rollback, but that didn’t work.

I tried ostree admin fsck which reported that I had a corrupt file with an unexpected checksum. I had just opened a port to quickly test a development django site, and think I may have been hacked.

Is it possible to completely reinstall the rpm-ostree tree? There is a command ‘ostree admin ostree-init’ that looks like it can do just that, but I haven’t been able to find a tutorial or post about using it, just the man page.
Is there any way to see if this issue is the libsolv one?
My journalctl -xe give me this:

rpm-ostreed.service: Failed with result 'signal'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ The unit rpm-ostreed.service has entered the 'failed' state with result 'signal'.
Feb 14 16:06:53 localhost.localdomain systemd[1]: rpm-ostreed.service: Consumed 20.284s CPU time.
░░ Subject: Resources consumed by unit runtime
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ The unit rpm-ostreed.service completed and consumed the indicated resources.

output of ostree fsck…

error: In commits 770583a12e2a2e1375640adaa2e4a9af50014a9eba7957e21c18519405436992: fsck content 
object 0836c4a4cccc5bc8bb34ede8edee097fa21fb6b66d09978ae6d710b6913208c6: 
Corrupted file object; checksum 
expected='0836c4a4cccc5bc8bb34ede8edee097fa21fb6b66d09978ae6d710b6913208c6' 
actual='b0fca340b7e1ebbc912cd87d6fe9a51a56b1ca8676e3795bd80493c34f6a0718'

output of ostree admin status

* fedora 770583a12e2a2e1375640adaa2e4a9af50014a9eba7957e21c18519405436992.0
    Version: 33.20210212.0
    origin: <unknown origin type>
  fedora 0e2cb97e4a2f3d210204b844a61bdda39f44d69702a8c0ea23f9c6c9e40b84e4.0 (rollback)
    Version: 33.20210208.0
    origin: <unknown origin type>

first time I run rpm-ostree I get the following message:

error: Could not activate remote peer.

the next time I run the command I get :

2 metadata, 0 content objects fetched; 788 B transferred in 3 seconds; 0 bytes content written
Checking out tree b83271d... done
error: Bus owner changed, aborting. This likely means the daemon crashed; check logs with `journalctl -xe`.

and with --peer:

sudo rpm-ostree update --peer
Running in single user mode. Be sure no other users are modifying the system
error: Failed to spawn child process “rpm-ostree” (No such file or directory)
1 Like

I have used rpm-ostree reset, and will have to reinstall the packages that I need, but at least it updates now.

I am having the same issue. Posted about it here although it may not have been the most appropriate place.

I 've spent ( :frowning: ) considerable amount of time this weekend grappling with this problem. At least I managed to find a work around on how to upgrade my system until this is resolved. For those not wanting to read the whole post, here is the workaround:

# Get commit id of latest image:
$ sudo ostree pull fedora:fedora/33/x86_64/silverblue --commit-metadata-only --depth=4
$ sudo ostree log fedora:fedora/33/x86_64/silverblue
# rebase onto that image (change commit id below as appropriate)
$ rpm-ostree rebase b83271db867324481a36c113aeb037f12a672e8263286bf046e9f522a0d71d18