Upgrade issue — Bus owner changed, aborting

Hi, there.

I’m using Fedora Silverblue 30. And I’m having trouble upgrading.

I’m getting this error: Bus owner changed, aborting. on running rpm-ostree upgrade .

I also checked this discussion forum — Bus owner changed, aborting when trying to upgrade — didn’t get it completely and ain’t there a solution, too.

Appreciate your help guys.

Great day.

same here https://github.com/fedora-silverblue/issue-tracker/issues/4

try “rpm-ostree update”

No, it didn’t work.

I thought there’s a problem with kernel. Turns out there isn’t.

I’m not completely sure about it. But I know, cause I installed Fedora Silverblue 29 on my system from scratch — Completely wiped the installed FSB30 — and upgraded it to latest kernel version 5.1.17.

Then I did a major upgrade from FB29 to FB30. Still the problem persists, though I’ve latest kernel version.

I really have no idea what’s the cause of the problem.

Oh, and I found this issue on Pagure which was issued 3 months ago.

And it’s maintained by @sanja. Maybe she can drop some light on this.

I can’t even install apps from flathub.

That I forgot to mention.

What’s going on your side? Have you figured out how to fix this issue?
I’d like to know.

only with “upgrade” does not work, update and install works.

GNOME Software crashes when trying to update

try sudo ostree fsck
and
sudo ostree admin cleanup

This is what I got on running sudo ostree fsck and sudo ostree admin cleanup.

After restarting the system, I got the same error on upgrade.

I have the same error. I can’t upgrade the system.
Silverblue Rawhide.

If you are getting ostree fsck errors, try resolving them using these steps: https://github.com/ostreedev/ostree/pull/345#issuecomment-262263824

I don’t know if it will resolve your upgrade problems, but it is still a good idea.

was fixed in the last update

https://bugzilla.redhat.com/show_bug.cgi?id=1697566

https://bugzilla.redhat.com/show_bug.cgi?id=1730451

1 Like

That’s cool.
Thank you for the update. :grinning:

BTW, that means I can update like I do usually. rpm-ostree upgrade .
How does the system knows the bug is fixed if it isn’t updated due to the very same error?

If you are facing this issue and are unable to upgrade to the fixed version of curl, you can install it temporarily to get upgrades working again:

$ sudo rpm-ostree usroverlay
$ curl -LO https://kojipkgs.fedoraproject.org//packages/curl/7.65.3/1.fc30/x86_64/curl-7.65.3-1.fc30.x86_64.rpm
$ sudo rpm -ihv curl-7.65.3-1.fc30.x86_64.rpm
$ sudo systemctl restart rpm-ostreed

And then retry rpm-ostree upgrade

Once you reboot, the temporary usroverlay is discarded and you’ll be in the latest deployment with the fixed version of curl

2 Likes

Thanks Micah, can you also add a
systemctl restart rpm-ostreed before the upgrade? It’s going to be necessary in general.

1 Like

Good catch; I’ve added it.

1 Like