Rpm-ostree support in KDE Discover

I am using Kinoite Rawhide builds, and it works well, but I still have to install updates from the command line. Is there any page that shows current status of rpm-ostree support in KDE Discover?

Initial support was added in Add support for rpm-ostree (!109) · Merge requests · Plasma / Discover · GitLab but is not yet enabled in Fedora’s Discover RPM. This is on my TODO list but help is appreciated if anyone wants to give it a try. It’s a small change in Overview - rpms/plasma-discover - src.fedoraproject.org.

In progress work in Commit - rpms/plasma-discover - 81b87899473c5171760dee64ef784e93b732005a - src.fedoraproject.org

I can see this is merged upstream on Rawhide but this is Fedora 36 right now. Will it land also on branched Fedora 35?

Yes, I’m working on fixing some remaining bugs and will backport all that to F35 ASAP.

I can see something is started to work on branched Fedora 35 Kinoite

But with a lot of issues. The issues I found:

  • no way to preview package changelog in KDE Discover GUI
  • an update is showing in “Addons” section instead of “System updates”
  • there is no any progress reporting after start the update
  • there is no feedback about update finish

Thanks for the feedback.

Unfortunately the support in Discover is not in a good state in 5.22 and I’m working on fixing that for 5.23 (PRs: #158 & #166). I’ll probably have to disable the support in Discover for F35 until 5.23 is released in F35.

This makes sense. Can you file an RFE at bugs.kde.org?

I’ve fixed that in the first PR mentioned above.

I’m still investigating this and I have not found the root cause for now.

Created: 443071 – Show package changelog

1 Like

I’ve disabled rpm-ostree support in Discover until I’ve fixed the remaining issues.

any updates about this feature?

Still blocked on bugs that I have not been able to resolve yet: Draft: rpm-ostree: Collection of changes to improve backend robustness (!166) · Merge requests · Plasma / Discover · GitLab.

Any debugging help welcomed!