How can I disable the fedora Repo in Plasma Discover and should I?

Hi, I use Discover rarely, while I use tonywalkers autoupdate script to get Fedora updates every day.

I really dont want any updates through discover, as these are probably already installed and will be applied on reboot, I just use it to discover Flatpak apps.

As rpm-ostree is so slow, opening Discover is a pain. Its awesome that there is now great rpm-ostree support, but I dont want to use it like that.

The system repo is greyed out, I cant disable it there.

I already set system updates to manual in the KDE settings.

Questions: as Discover now works, should I remove the autoupdate script and use the KDE tools with autoupdates on? It uses packagekit, is that somehow better? Would there be a performance decrease? Rpm-ostree already hogs all my network bandwith, so I dont think it would be worse, and going the official way is always easier.

I don’t use Kinoite, but think this would apply.
Discover does not honor repo include/exclude statements

1 Like

Hi, yes your issue is the same as mine.

Its pretty annoying that it still exists, so I would keep this thread open.

1 Like

Yeah, agreed but as you can see from the link, I opened this about 2 years ago and also reported it to PackageKit. The response has been pretty much crickets. As I understand it, Discover relies on PackageKit. The maintainer of PackageKit announced the retirement in 2019. If you ask, you’ll get an “oh, of course it’s maintained” but the reality is it appears to be in a kind of pseudo-support mode where people are keeping it going so things don’t implode, but unless something is absolutely needed, it’s not getting done.


Okay so either we keep not using Gnome Softeare or Discover (I guess other GUI appstores too), or someone fixes it. Lol.

There are thousands of people using it, and I think its a very useful project, even though with Flathub only you dont really need it.

I only use Discover on occasion to help update Plasma widgets, the rest of the time it stays hidden. For updates I prefer using DNF Offline Upgrading. Work is going on currently with DNF5, which will provide a new alternative to PackageKit for RPMs, but presumably that has to be finished and available first before Discover or other packages use it.

The repo files for rpm-ostree in /etc/ostree/remotes.d don’t behave like dnf repo files do and do not have an enabled option to toggle them, nor does the rpm-ostree command have a --enablerepo= option like dnf offers on the command line. Personally I just use the CLI for updating or installing Flatpaks since it’s faster than the UI and I can see what’s happening.

1 Like

Thanks for the info, that was what I needed. I guess there will already be an issue about that problem.

Yes me too, I use autoupdates for rpm-ostree and flatpak, as its so much more stable, and also install apps.

But the GUI software centers show so much more info:

  • Images
  • License
  • Description
  • Reviews
  • Code
  • Donate
  • Release date

I guess Flatpak can do many of these too, I will look and add a shortcut to this bash shortcuts project

Thanks for the clarification. I don’t use Silverblue thus didn’t pickup on the hint about “tonywalkers autoupdate script”. However, for those who don’t use Silverblue and ostree, my comments will apply.

1 Like

Fedora Kinoite does not use PackageKit or DNF Offline Updates.

There is currently no easy way to disable rpm-ostree support in Discover now that it has been added. One option is to remove the RPM with:

$ sudo rpm-ostree override remove plasma-discover-rpm-ostree

Thanks, maybe one could use Discover and Gnome boxes in Distrobox only to browse Flatpaks, but then you can also most of the time just use

Because Discover and Gnome software are pretty nice for searching apps!