Rpm-ostree broke with input/output error, can't take any actions

I tried:

  • Rolling back
  • Changing commit
  • Removing overlays
  • Updating
  • rpm-ostree reset
  • ostree fsck

In all scenarios I get this error:

error: Checking out deployment tree: openat(ea/826b8a90b741801c51fd33c2ef2d7d4f4b7302ccaac8d5b63eb9f365e3df56.dirtree): Input/output error

For example:

I] raphael@fedora ~ [1]> rpm-ostree update
2 metadata, 0 content objects fetched; 788 B transferred in 4 seconds; 0 bytes content written
Checking out tree a492d00… done
error: openat(ea/826b8a90b741801c51fd33c2ef2d7d4f4b7302ccaac8d5b63eb9f365e3df56.dirtree): Input/output error

I don’t know what caused this as I have not touched any system files or the rpm-ostree db command. If I need to reinstall my confidence on Silverblue will be completely lost.

[N] raphael@fedora ~ [1]> rpm-ostree status --booted
State: idle
● fedora:fedora/35/x86_64/silverblue
Version: 35.20220317.0 (2022-03-17T15:07:35Z)
BaseCommit: 4792b2c093e299a8fd3f5be3ce5b40568b2110c69acddb768179a116a52dab93
GPGSignature: Valid signature by 787EA6AE1147EEE56C40B30CDB4639719867C58F
RemovedBasePackages: firefox 98.0-2.fc35 gnome-software gnome-software-rpm-ostree 41.4-1.fc35
LayeredPackages: fish gnome-screenshot moreutils ranger simple-scan
LocalPackages: grc-1.11.3-6.fc34.noarch

I tried removing this grc package but I’m unable to, gnome-software was removed because it’s an annoyance every day even with “Check for Updates” disabled. This system is updated daily with flatpak update;rpm-ostree update

Try rpm-ostree cleanup -m, then try the update again. If all else fails, boot into the previous deploy (you will need to select it from the boot menu by holding shift key at boot), then update from that deploy instead.

1 Like