Right click menu distorted

I have built a new system with a fresh install of Fedora 38 KDE plasma.
AMD: 7950x
Ram: 128GB
SSD: 2tb
GPU: Nvidia 1080

after installing RMPfusion NVIDIA driver 530.41.03 I had to manually update grub to include “nvidia-drm.modeset=1” in GRUB_CMDLINE_LINUX.

The issue is with explorer windows and right click menus.
The best example i have is when i right click the desktop the menu is distorted or missing items. see screenshot below.

I have tried to make adjustments to different settings in “Appearance and global theme” and tried different setting for display like scaling and different resolutions but nothing seems to fix the issue.

Not sure if this is an issue related to nvidia, Fedora 38, or KDE.

Would any one have any suggestions or ideas?


After spending hours trying to resolve the issue, it appears to be a problem with the GPU driver. However, I was able to resolve the problem by installing older drivers with another fresh install of Fedora 38. After confirming that the issue was resolved, I encountered a new problem with the “Failed to start nvidia-power service” error after a few restarts.

I have been using Rocky 9 workstation for the past 5 months and found it easy to install nvidia drivers. However, my experience with Fedora was not as smooth, although it may have been due to using Rocky 9 with Gnome. While I wanted to give Fedora KDE a try and love it, it seems that it may not be the right fit for me.

Therefore, I have decided to try Kubuntu, which was painless to install on the first try.

This is only a notification, not an error, and can be ignored.
That service only works on a few laptops with specific optimus configs.
If you want it can be totally removed by uninstalling the nvidia-powerd package.
dnf remove xorg-x11-drv-nvidia-power will work if you choose.

This error occurred during startup, and I received that message that left me without a GUI, forcing me to login with alt+F2(tty). Even after attempting to set “set-default graphical.target or multi-user.target,” the issue persisted. However, I have since moved past these issues.

At this point, I am taking a wait-and-see approach with Fedora. I may re-evaluate in a few months or years, or I may decide to never use it again.

I wanted to love it!

Same problem here with amd graphics.
For me this happens only if I have two monitors active with different DPI setting.
My primary is 2560x1440 with 120% scaling and secondary is 1440x900 with 100% scaling.

If i disable the secondary monitor or drop the scaling to 100% on primary, it fixes the issue.

I have a similar thing occuring sometimes, while I use amdgpu and an AMD Vega 8 Graphics Laptop. Not sure if its really the GPU drivers.

In my case (this got better with an update but still occurs) the context menu is invisible and only appears after I hover over it