Fedora 38 Nvidia driver issue

Hello everyone, recently i doing clean Fedora 38 install and run into issues with nvidia proprietary driver

The problem was with Phantom monitor(none-1-1) and freezing Wayland session

After some workarounds i found that problem is due to nvidia-drm.modeset=1 kernel option not set

Steps i do to fix the problem:

  1. Open grub config sudo nano /etc/default/grub
  2. Add nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX line
  3. Update grub config with sudo grub2-mkconfig -o /boot/grub2/grub.cfg command
  4. Reboot the system

After this all works like a charm

P.S. Problem occur on Fedora Workstation 37/38, KDE Plasma spin 37/38 fresh installs

1 Like

After I upgraded to Fedora 38 I also found the driver was not functioning. I force-reinstalled the driver and worked fine.


I was experiencing similar issues with F38; a “phantom” monitor as well as GDM not fully loading, and being left at a gray screen, unable to login.
Using pkill gdm or systemctl restart gdm from tty 2 allowed me to login and add nvidia-drm.modeset=1 to the kernel line as noted by the OP.
From a brief search, it appears that whomever is affected by this will likely continue to require this workaround for quite a while, as it seems that kernel developers and Nvidia can’t seem to get together on this.

Mind in sharing the details on how to re-install the drivers? I’m still googling and most things I find either assume it’s installed by default, or don’t go step by step, and assume a log of Fedora specific knowledge. BTW: My issue might be cause I use netinstall (instead of Everything ISO)

If you installed nvidia from rpmfusion you should be able to run
sudo dnf reinstall akmod-nvidia
You can also check out this page as well

I have noticed on a couple new installs that the nvidia-drm-modeset=1 seems no longer to be added into /etc/default/grub. If an older install already has it the option is not removed, but a new clean install seems to no longer receive that option in the kernel command line.

Don’t have a clue why it would change, but it seems to have done so from rpmfusion.

Incidentally, upgrading to kernel 6.3.5-300 broke this again for about a week, even with the workaround. 6.3.6-200 seems to have fixed it.