Removing Fedora 39 restoring Fed 38 completely

Hi all, I was a bit quick in installing Fedora 39. As it turns out, there is a two week delay before the final (stable) version will be released.
I have a dual boot system, with two hard drives. Primary is Fedora 38 with a second Fedora 38 (since the install of Fed 39) and a Fedora 39, plus a very old version of Fed 33, which never seems to go away. On the second hard drive is Windows 10.
When I installed the (too early) Version of Fed 39, it installed without the previously installed (on Fed 38) Protonvpn. Now I can’t get the Protonvpn to install on the Fed 39, or Fed 38 that was left on the hard drive.
My question is, can I remove the Fed 39 and wait till the final release is released? Will that allow the preexisting Fed 38 to be completely functional where I can reinstall Protonvpn? Why are there now 2 versions of Fed 38 listed when I start up the system?
On top of it all, when Fed 39 starts up, it says, NVIDIA is not working, falling back to nouvo (?)
Thank you for any constructive solution to this complicated story.

The grub menu lists bootable kernels.

Are you sure you really have a f38 file system installed?
If you boot into your f38 what is in /etc/fedora-release?
Does it say f39 by any chance?

1 Like

Hi Barry, please see attached “Screenshots”. One logged in as Fed. 39 the other I chose as Fed. 38.
In the Terminal readouts, it says Fed. 39, but lists Fed. 38 as k38 as kernel

The one line that is in white is Fed. 39.
But above it are two Fed. 38’s listed as kernels.On all, I have no Protonvpn, especially in Fed 39, while I completely removed all packages.
That’s why i would like to remove Fed. 39mand restore Fed 38, until the new “Clean” Fed. 39 is released.
Proton says they will wait for the new release and then write the packages necessary to install Protonvpn on Fed 39.
In the meantime, i thought redo Fed 38 and reinstall the working protonvpn software there.
Till now all the versions of ProVPN have not worked on Fed 39.
Hope this is clear enough for you.



Hi Barry, I reinstalled Fed. 38 & Protonvpn. When I check the Terminal for Version, it shows Fed 38.
Then i reinstalled ProtonVPN, both seem to be working.
I’ll leave at this for now until the Fed 39 Stable is released and Proton has offered the new packages for their VPN.

Thank you for your interest and feedback.



There are no real difference between f38 and f39 kernels. After a normal upgrade to f39 after the release date, you will still get the two previous f38 kernels list in the boot menu. And they would work just fine.

Pity, all this work, because the actual F39 is close to release and perfectly usable. Culprit at Proton is the dependency “python(abi) = 3.11” while F39 offers 3.12.
I did not find a way to get around of this. So please wait for Proton offering an app for F39 before upgrading to F39.
Alternative at Proton is downloading an ovpn file and importing that in NetworkManager, only be sure that IPv6 is switched off to prevent leaking via IPv6, if available.

1 Like

Hi h.janssen, thanks for your concern, feedback and tips.
Will wait till all is available, I just went to quickly with the F39 upgrade, my own fault.
That’s life, live and learn…

Best regards,


Hi Villy,
Thank you for your input.
I am content with the system right now. F38 is working and I have ProtonVPN up and running too.
Will wait till all the new packages are functional.

Thanks again,


Flatpak, Appimage, (rootful) toolbox container maybe. But these are either not available or not that easy to do.

I use some third party software that provides a Java GUI with some python command-line utilities. Previous Fedora releases included older Python packages. Still on Fedora 38 here, I see:

% dnf5 search 'python3.1' | grep \[0-3].x86_64
 python3.10.x86_64: Version 3.10 of the Python interpreter
 python3.12.x86_64: Version 3.12 of the Python interpreter
 python3.13.x86_64: Version 3.13 of the Python interpreter

Older Python versions have been available in Fedora for several years, so it would be surprising if 39 doesn’t allow us to use (slightly) older python versions.

You can install all python versions from 3.6 to 3.13 on f38 and of f39.
Which is a great resource for testing python.
Only the system python will have packages you can install via RPM.

So, Proton requires:

python(abi) = 3.11

but even if you install python3.11, you have no chance to run this software without doing nasty things because all python modules are in the 3.12 subfolders and unavailable as 3.11 rpms.

So rpm-based software using python: not usable as long as the third-party supplier provides no version matching the OS release with the correct python version.

So you need a Fedora 38 container plus the knowledge how to setup the network upside-down using the container to connect to the internet and transfer the vpn network to the foreground…

The app is not required to get protonvpn working on linux according to their website: How to use Proton VPN on Linux

You can configure OpenVPN or WireGuard manually on Linux using either NetworkManager or the command line. This may be useful on devices not supported by our Proton VPN Linux app, but if we retire a server, you may need to download new configuration files.

I also wonder if the app will work on 3.12, which would require some investigation of the RPM contents.
To do this I would use rpm2cpio to get the files out of the RPM to review.

1 Like

Yes, it works fine via NetworkManager only, if you take care of IPv6, the app creates a
ipv6leakintrf0 interface which blocks IPv6 and makes users desperate which do not properly close the VPN before shutdown.

I did something in the category “Do not try this at home”: installed all rpms in a separate directory, changed from this directory usr/lib/python3.11 into usr/lib/python3.12, made a tar file and unpacked this dir in the root directory.
The app works, looks different from what I was used too but that’s may be half a year ago. Could login and setup a (free) VPN connection, got tray icon in LXDE.
And the ipv6 block connection is deleted upon VPN shutdown.
So may be the guys at Proton do not have that much work for F39…

I’ve only a OpenVPN problem that it keeps asking a password, but I had this before with NetworkManager.

Hi h.janssen,
thank you for your efforts / time but no more experimenting for me.
I’m just going to patiently wait for all the new packages to be released.
Then I will update everything when it is all out and safe to install.
I’m not that technically gifted to start with something that I don’t have step by step instructions for.

Thanks again,

best regards,


Poorly, especially the MullvadVPN app has nice features like integrated DNS setting (this means instant captive portal working when disabling the VPN, but secure DNS when on) and split tunnelling.

So happy that Mullvad doesnt suck ;D

Just try it :slight_smile:

On that linked website, find out how to download your wireguard config as a file

in network settings, click on “new connection” and choose “wireguard” (mullvad has shitty openvpn support but its better for privacy, no idea of proton)

Open the wireguard config file here, and it should all just work. Its KDE, just look around the settings, search the internet a bit maybe and its fine

Fedora 39 is official now and Proton has it’s fedora 39 repository available, so you can upgrade again…

1 Like