Removed Flat Remix Icons and Now Have Flat-Remix-Blue-Light.rpmmoved etc

I downloaded and installed the Flat Remix Icons through the dnfdragora software. I then removed them with sudo dnf remove [...] and all but four were removed.

Now, I see them via Gnome Tweaks>Appearance but with a .rpmmoved extension:

  • Flat-Remix-Blue-Light.rpmmoved
  • Flat-Remix-Green-Light.rpmmoved
  • Flat-Remix-Red-Light.rpmmoved
  • Flat-Remix-Yellow-Light.rpmmoved

Where did they go? How in the world can I clean that up?

I haven’t used the “flat remix” icons. Would you know what packages these were please? The only files that are not touched by rpm during transaction are configuration files. So it’s possible that these are configuration files left over after the uninstallation and so require manual removal.

Thank you for the reply. My apologies for the delay.

The packages installed are the following:

 Package                   Arch       Version                 Repository   Size
 flat-remix-icon-theme     noarch     0.0.20211214-2.fc35     updates      81 M
Installing dependencies:
 gnome-icon-theme          noarch     3.12.0-16.fc35          fedora      9.6 M
Installing weak dependencies:
 flat-remix-gtk2-theme     noarch     0.0.20220330-1.fc35     updates     2.0 M
 flat-remix-gtk3-theme     noarch     0.0.20220330-1.fc35     updates     3.0 M
 flat-remix-gtk4-theme     noarch     0.0.20220330-1.fc35     updates     226 k

Transaction Summary
Install  5 Packages

Total download size: 96 M
Installed size: 435 M
Is this ok [Y/n]: 
Downloading Packages:
(1/5): flat-remix-gtk4-theme-0.0.20220330-1.fc3 169 kB/s | 226 kB     00:01    
(2/5): flat-remix-gtk2-theme-0.0.20220330-1.fc3 901 kB/s | 2.0 MB     00:02    
(3/5): flat-remix-gtk3-theme-0.0.20220330-1.fc3 1.1 MB/s | 3.0 MB     00:02    
(4/5): gnome-icon-theme-3.12.0-16.fc35.noarch.r 2.3 MB/s | 9.6 MB     00:04    
(5/5): flat-remix-icon-theme-0.0.20211214-2.fc3 7.8 MB/s |  81 MB     00:10    
Total                                           8.4 MB/s |  96 MB     00:11     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Running scriptlet: flat-remix-icon-theme-0.0.20211214-2.fc35.noarch       1/1 
  Preparing        :                                                        1/1 
  Installing       : flat-remix-gtk3-theme-0.0.20220330-1.fc35.noarch       1/5 
  Installing       : flat-remix-gtk4-theme-0.0.20220330-1.fc35.noarch       2/5 
  Installing       : flat-remix-gtk2-theme-0.0.20220330-1.fc35.noarch       3/5 
  Installing       : gnome-icon-theme-3.12.0-16.fc35.noarch                 4/5 
  Installing       : flat-remix-icon-theme-0.0.20211214-2.fc35.noarch       5/5 
  Running scriptlet: flat-remix-icon-theme-0.0.20211214-2.fc35.noarch       5/5 
  Verifying        : gnome-icon-theme-3.12.0-16.fc35.noarch                 1/5 
  Verifying        : flat-remix-gtk2-theme-0.0.20220330-1.fc35.noarch       2/5 
  Verifying        : flat-remix-gtk3-theme-0.0.20220330-1.fc35.noarch       3/5 
  Verifying        : flat-remix-gtk4-theme-0.0.20220330-1.fc35.noarch       4/5 
  Verifying        : flat-remix-icon-theme-0.0.20211214-2.fc35.noarch       5/5 



I tried to reinstall it and the rpmmoved extension went away. Then I uninstalled it and the same ones came back.

You go to /usr/share/icons and remove files and folder using cli. Not specific to Fedora …


Apologies it’s not specific to Fedora, I did not know. Thank you for the help! I appreciate it.

Sorry @marko23 : why does one need to remove the files manually? All files installed by the rpm should be owned by it, so that if they are installed by the rpm, they should be removed by the rpm also. So, if that isn’t happening, this is a packaging bug.

.rmpmoved isn’t standard package name but a package bug. I looked around for a while with same problem and finally searched in the whole file system for things suffixed . rmpmoved that brings you to /user/share/icons with folder Flat-Remix … logical but strange …

1 Like

Hrm, I think if removing the rpm isn’t removing all files from the package, that’s a packaging bug that should be reported. I don’t see a bug here about this, so could you folks file one please?

If a system is upgraded from a version less than or equal to flat-remix-icon-theme-0.0.20211214
That system will end up with .rpmmoved directories for:

This commit moves and ghosts the above directories referencing Replacing a symlink with a directory or a directory with any type of file :: Fedora Docs which also references Bug 447156 - [RFE] Add support to changing directory to symlink (and vice-versa) when doing upgrade/downgrade/reinstall

I’m not sure this is a bug, at least with the icons or gnome-tweaks?


1 Like

I’d still say it’s a bug, but I haven’t looked into what component it is with too.

It’s fine to replace whatever with *.rpmmoved, but when the package is uninstalled, this should be removed. The docs confirm this:

“Additionally, you should define the /path/to/dir.rpmmoved directory as a %ghost entry in the %files list in the package’s spec file, so that the directory is not entirely orphaned and can be deleted if the package is ever uninstalled and the directory is empty.”

So, unless the user her put something in the directory to make it “not empty”, it should be removed on uninstalling the package.

So, if the spec is fine, it’s a bug with rpm itself (!)—which isn’t removing the files.

I guess we’ve solved the issue here, and if anyone is interested, they can follow up to isolate the component.

1 Like