Reinstall fedora on dual boot, problem with uefi partition

Fedora 31 installed OK on a Windows 10 system with UEFI. I tried to reinstall with a different configuration for the LVM using BLIVET. The new blivetconfiguration worked when installing as a KVM guest, but fails on the laptop dual boot disk. Blivet complains that there is no GPT configured EFI partition specified. I have tried editing the existing EFI partition to specify its mount point as /boot/efi as well as telling blivet to delete the partition and create a new one with same mount point. The installation fails if having blivet ignore the issue and continue. Am stuck. Thanks for any help.

Welcome to the forum. Please make sure you read the “New Users Start Here” thread so your posts contain all the needed info for us to assist.

I had a similar problem with blivet, and wound up switching back to the custom install method to complete a recent new install dual boot.
The EFI partition will be under the Windows portion of the drive. Having blivet delete that one can cause problems booting into windows, but both OSs can easily share a single efi partition.
F32 install also now requires /boot to be a standard partition and not part of the LVM space.

EFI partitions have a specific GUI value… so you would have to “flag” the partition to be an EFI partition… Sorry I don’t remember how it is done in the installer. EFI partitions are supposed to be FAT32 partitions… and I think about 200 Mb… I am very unsure about this one. May be called ESP (Efi System Partition).

Hi, thanks for the reminder to read the directions before opening the box :slight_smile:

Below is a more complete description of the problem scenario.

In order to be compatible with an important application the Fedora LVM must be on top of a LUKs partition, like this:
$ lsblk

NAME                                          MAJ:MIN RM  SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0  477G  0 disk  
├─sda1                                          8:1    0 1000M  0 part  /boot
└─sda2                                          8:2    0  476G  0 part  
  └─luks-7fd6d941-c331-4101-80d8-aecc5ced7980 253:0    0  476G  0 crypt 
    ├─vg_oc8064015851-lv_swap                 253:1    0    8G  0 lvm   [SWAP]
    └─vg_oc8064015851-lv_root                 253:2    0  468G  0 lvm   /

Blivet supports creating an encrypted LVM partition on a KVM guest that meets requirements and looks like this:

$ lsblk
NAME                                        MAJ:MIN RM  SIZE RO TYPE  MOUNTPOINT
sda                                           8:0    0   30G  0 disk  
├─sda1                                        8:1    0 1023M  0 part  /boot
└─sda2                                        8:2    0   29G  0 part  
                                            253:0    0   29G  0 crypt 
    ├─bfklvm-02                             253:1    0   15G  0 lvm   /
    ├─bfklvm-swap                           253:2    0    2G  0 lvm   
    └─bfklvm-01                             253:3    0   12G  0 lvm   /home
sr0                                          11:0    1 1024M  0 rom

Asking the Fedora installer to encrypt resulted resulted in the following layout on my dual boot machine. This does not meet lvm-on-luks requirement:
$ lsblk
nvme0n1 259:0 0 477G 0 disk
├─nvme0n1p1 259:1 0 260M 0 part /boot/efi
├─nvme0n1p2 259:2 0 16M 0 part
├─nvme0n1p3 259:3 0 237.4G 0 part (Windows system partition)
├─nvme0n1p4 259:4 0 1000M 0 part
├─nvme0n1p5 259:5 0 1G 0 part /boot
└─nvme0n1p6 259:6 0 237.3G 0 part
├─fedora-root 253:0 0 50G 0 lvm
│ └─luks-cf99766e-3660-4c43-9df2-57bc5171c064 253:2 0 50G 0 crypt /
├─fedora-swap 253:1 0 7.8G 0 lvm [SWAP]
└─fedora-home 253:3 0 179.5G 0 lvm /home

To reinstall Fedora on the dual boot machine I used Fedora-live to delete nvme0n1p6 partition, then had Blivet create the partition in exactly the same way it was done on the KVM guest. All looked good until Blivet complained about not having a GPT EFI System partition, even after specifying its mount point to be /boot/efi: However, all indications are that the existing partition meets all requirements.

$ sudo fdisk -l /dev/nvme0n1

Disk /dev/nvme0n1: 476.96 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: WDC PC SN520 SDAPMUW-512G-1101
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt <============== GPT format partition table
Disk identifier: 75EA049F-…
Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 534527 532480 260M EFI System <========== correct partition type
/dev/nvme0n1p2 534528 567295 32768 16M Microsoft reserved
/dev/nvme0n1p3 567296 498454527 497887232 237.4G Microsoft basic data
/dev/nvme0n1p4 998166528 1000214527 2048000 1000M Windows recovery environment
/dev/nvme0n1p5 498454528 500551679 2097152 1G Linux filesystem
/dev/nvme0n1p6 500551680 998166527 497614848 237.3G Linux filesystem

$ sudo minfo -i /dev/nvme0n1p1
device information:

Actually found the same complaint at
It appears the bug was simply ignored and then dropped :frowning:


The problem was solved by using the fedora 32 installer, no complaints from Blivet.


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.