Realtek 8814au chipset driver for Fedora 30

I have installed the Fedora 30 fresh on my desktop, and unfortunately, there is no way for me to use the LAN, so wifi dongle is the only option. I have 3 of them, Netgear Wndr3100v2, EDUP EP-N1571 and Edimax ac1750.
EDUP is recognized by the Fedora during the install, and I can use it without any issue, but it is the slowest one, so I’m trying to use the other two.
Netgear uses the broadcom bcm4323 chip, which by my search, seems not really Linux friendly, so I just focused on the Edimax one.
Edimax didn’t provide a driver for kernel higher than 4.4, but they do provide a solution for the same chipset, rtl8814au. Here is the link: EW-7833UAC : EDiMAX.
UNFORTUNATELY, I got stuck at step 8, " dkms build -m rtl8814au -v 4.3.21". I got an error 127 for the make.
But I have no problem if I tried to do the same for the 8812au chipset, almost the same steps from another instruction link.
I did search the old for the 8814au chip, but seems can’t find a good answer.

Anyone have experience with the rtl8814au chipset on the F30, or even F29/28…?


You going need to give us the actual error, error 127 covers a couple of things. Including missing file(s), its probably a dependency that needs installing. Will be able to advise further with the actual error. You may need to look at the last couple of lines before the error 127.

Thanks Tom.

Hi Tom

I finally solved the problem by install the 8812au driver instead of 8814au. It seems that I’m not the only one that have the problem. Now I need to find out that link again, since I need to reinstall, for some reason, I can’t boot into the rescue mode, getting “kernel not found” error.

1 Like

So here is the exact steps that if you just installed the Fedora 30 fresh, and hasn’t done anything yet. I’m a newbie to the Linux word, so just correct me if I’m wrong, but this is what I typed on my terminal to get the driver installed. And yes, use the 8812au clone from git.
1> Update the system to the latest, then reboot. Use the software GUI to update/reboot or
sudo dnf update
sudo dnf reboot
2> sudo dnf install kernel-devel kernel-headers dkms git
3> git clone
4> cd rtl*
5> make (it is possible saying can’t find it and asking you to install, so just follow it)
6> sudo make install
7> sudo ./
8> reboot
9> ENJOY the fast wifi dongle!


For future reference, if you are using dkms; you can miss out steps 5 & 6.

Thanks Tom.

Excellent tutorial and very well explained!