Read-only DVD Drive - why?

I created a Fedora-34 live DVD on Ubuntu on this PC and installed Fedora-34 on this PC from it.
I now want to use the same drive to create a Fedora-35Beta live DVD, but the drive is now read-only. I have replaced the drive, but it’s still read-only so it’s not the drive. Does Fedora do this by default? Do I have to use root to change some permission?

Are you trying to re-use a DVD?

Most DVDs are write-once media. Is it specifically a rewritable DVD?

1 Like

I’ve tried both DVD-RW and DVD+RW.

ANY DVD that has been written and closed so it can be used is read only. That is a feature of ALL DVDs, CDs, and BluRay disks and has been so since the first optical disk was created.
CD-RW & DVD-RW disks can be added to as long as they were written in RW mode and the final closure was not made.

The ISO image used to create the DVD for fedora 34 workstation is closed so the act of burning it to the DVD will automatically give a closed device.

Why not use a USB stick to write the ISO image to (and boot and install from) then it can be reused, unlike the DVD disk.

1 Like

I never had any problem with this in Ubuntu, so there is nothing wrong with the drives or the disks. I could just rewrite a disk or format it using “Disks” or Brasero. I have just used on of the disks to create a Fedora-35Beta live disk using *******-7.
I have just tried an unused DVD-R disk and an unused DVD-RW disk, in both cases the drive is shown as read-only in “Disks”. The drive shows as read-only with or without a disk.

I tried formatting a disk on an Audio-Visual DVD writer then checked the permissions of the files. The result is odd, I’d already seen this on a disk formatted on the computer.

One more thing to look at.
On my system /dev/cdrom is a logical link to /dev/sr0 which is owned by root : cdrom with rw permissions for both owner and group.

Is your user a member of the cdrom group?

I do not understand why that would show as Kernel Overflow User and group nobody.

If you are on fedora as it seems then /dev/sr0 should have default ownership and permissions.

$ ll /dev/sr*
brw-rw----+ 1 root cdrom 11, 0 Sep 18 11:16 /dev/sr0

I mentioned permissions in my original post, I had looked at my user permissions in “Settings” but there didn’t seem to be anything interesting. I think you may be on the right track.

[chris@fedora ~]$ ll /dev/cdrom*
lrwxrwxrwx. 1 root root 3 Sep 28 18:08 /dev/cdrom → sr0
[chris@fedora ~]$ ll /dev/sr*
brw-rw----+ 1 root cdrom 11, 0 Sep 28 18:08 /dev/sr0
[chris@fedora ~]$

Is your user a member of the cdrom group?

[chris@fedora ~]$ groups
chris wheel
[chris@fedora ~]$

I have only used file ownership and permissions for file and directories and wasn’t aware that they also applied to hardware.

The above checks suggest to me that the cdrom belongs to root, that the cdrom gives permissions to the “cdrom” group and that I am not a member of that group. I don’t know what “wheel” is unless it relates to my Python application.

How might I make myself a member of the “cdrom” group (and out of interest, how has it come about that I am not.)? I have tried

[chris@fedora ~]$ sudo useradd -g cdrom chris
useradd: user ‘chris’ already exists
[chris@fedora ~]$ groups
chris wheel
[chris@fedora ~]$

without success.

Note that using sudo gnome-disks, the drive still shows as read-only.

I am not sure any user is automatically part of the cdrom group.

You can see which groups you belong to with the command “groups”
You can add a user to a group with the command

sudo usermod -a -G examplegroup exampleusername and replace the examples above with the actual group and user name.
Finding out how to do things like that is as simple as a google query.

And yes, permisisions apply to everything on a linux system since everything is seen as a ‘file’ by the system.

You will have to log out and back in before the group change takes effect.

“as simple as a google query” didn’t work (see my previous post), but your command did.
However drive is still read-only (for root too)

Maybe the permissions of devsr0 are insufficient?

[chris@fedora ~]$ ll /dev/cdrom*
lrwxrwxrwx. 1 root root 3 Sep 28 18:56 /dev/cdrom → sr0

[chris@fedora ~]$ ll /dev/sr*
brw-rw----+ 1 root cdrom 11, 0 Sep 28 18:56 /dev/sr0

I’ve checked my notes and given everyone all permissions to “devsr0”.
sudo chmod 777 /dev/sr0

[chris@fedora ~]$ ll /dev/cdrom
lrwxrwxrwx. 1 root root 3 Sep 28 18:56 /dev/cdrom → sr0
[chris@fedora ~]$ ll /dev/sr*
brwxrw-rwx+ 1 root cdrom 11, 0 Sep 28 18:56 /dev/sr0
[chris@fedora ~]$

No good…

You may make the permissions change but that is only until the next boot because /dev is built with every boot.

Your issue seems to be that you expect something that is not possible. As stated, A closed optical disk can never be written to again. The drive itself can never be written to when it has no media, only the unused disk in that drive. Thus /dev/sr0 is not writeable. When you place an empty disk in the drive then tools designed to write to the drive can do so as they are writing to the media, not to the device.

That you expect to be able to write to a previously used optical disk (except formatted and unclosed RW disks) is beyond belief. 30+ years of optical disk history should be enough for anybody to understand that the optical disk is not writable once written to and closed. Even un-closed RW disks can only be written to with the proper tools.

In fact that is where the term CDROM came from (Compact Disk Read Only Memory). CD-RW (CD Re-Writable) came along later and never became popular.

Now, there is a way to allow any user to mount / unmount / and share the media in a CD drive, and that is with an entry in /etc/fstab to allow users to mount it. Read up with “man mount” & “man fstab” and see what the options “noauto”, “user” and “users” allow. Of course that still requires every user accessing it to be part of the cdrom group.

Your somewhat untactful comments on whether DVD-RWs can be re-written appear to be at odds with evidence on the Web and from my own experience with DVD recorders and computers over many years.

Again, you are missing one word I used. closed

understand that the optical disk is not writable once written to and **closed**.

I explicitly said that unclosed DVD-RW disks can be written to but once closed they cannot. Even the link you provided explicitly explains that.

When a rewritable disc has been finalized you can no longer modify the data on it but you can erase it and write to again.

That being said, unless I am missing something, I don’t think that relates to the OPs problem which is that the device is read-only in all situations.

@chrisofbristol, did you get yourself added to the cdrom group?

Also, you don’t need to have ownership of /dev/sr0. It has been a long time since I have used one of those devices but it is likely that access is provided via udev or polkit rules.

@dalto Agreed - thanks.
I have added myself to the cdrom group but it didn’t change the read-only status. Gnome-Disks still says that the drive is read-only whatever sort of disk I put into it. However I’ve just managed to write an iso file onto a previously used DVD-RW without any quibbles from Brasero. I’ll just ignore what Gnome-Disks says on this matter in the future…

1 Like

I think I understand the issue. I had not noted you were referring to gnome disks.

Gnome disks expects to create and write a partition table, which is not possible on an optical drive, therefore it shows as read only.
The drive/disk is actually usable with the tools designed for it.