DVD permissions issues - cannot use DVD


I have an F34 system. It was upgraded all the way over the past few years I think starting with F28 or so.

I recently upgraded to Fedora 34. Now I can’t use DVDs because of a weird permission issue. I stick a DVD in the drive, it shows up in the sidebar in nautilus. I click on it and get this permissions error


It’s pretty weird. I have searched around and not found any solutions, although one F18 post I found on another website suggested my user should be in the cdrom user group. I did add my user to this group, logged out, logged back, but the error persists exactly the same way.

I will post in a reply below a screenshot of what it looks like on the command line. I was finally able to access the contents of the disk from a terminal by doing the following as root

umount /run/media/{myusername}/{DVDDRIVENAME}
mount /dev/sr0 /media/dvd  /* I created /media/dvd */

Problem is this is a DVD I wanted to (legally! home movies!) rip, so I guess I’ll have to see if I can rip from VOB files or whatever, but this seems like a ridiculous workflow do this. It has been years since I’ve had to manually umount/mount anything, this normally just works. I am wondering if anybody has ideas on what this could be.

1 Like


rechecked here on an also undated F34 box:

ls -lR /run/media/
total 0
drwxr-x---+ 3 root root 60 26. Aug 20:16 ron

total 2
dr-xr-xr-x. 4 ron ron 136 30. Mär 2010  PT_ANESTHETIZE

please compare your and my last line:
your: d–x–x—
my : dr-xr-xr-x

mine is an commercial Music-Video-DVD (“Porcupine Tree - Anesthetize”)
I’m not in group “cdrom”
I’ve no idea why your read permission is missing.

I would recommend to recheck permissions with another/an commercial DVD too.
is only that DVD the culprit or your something else ?

Sometimes relogin is not enough as DM doesn’t kill stale processes by default.
You need to verify in the current session the change is applied correctly:


Also isolate SELinux related issues:

sudo setenforce 0; getenforce

And check the default mount options:

grep -e /run/media /etc/mtab

Perhaps you need to adjust some mount option like umask=0.
This should be possible with GNOME Disks or udev rules.

Before the upgrade to F34 with discs produced by the same machine I had this same issue. It doesn’t seem to matter which disk I use, though.

as said I’ve no idea what it could be, but I would suggestion to post this issue on Fedora user list too.

but wait, …

did you

  • run “sudo rpmconf -a” after update
  • relabel the filesystem via " sudo touch /.autorelabel" and a reboot
  • check with setroubleshoot

Dumb question here, but did you try sudo chmod 555 SAMSUNG_DVD_RECORDER_VOLUME ? (777 instead of 555 if you’re wanting to write to the DVD)

@mhdave i hope you saw that the topic is about F34 and it is EOL ?!
Aug '21 relies to August 2021.

I did and saw that it was reopened. Answer is generic procedure applicable to all Fedora releases, right? We are teaching people how to troubleshoot and repair. For the most part we tell the same story and problem solving process for each release.
A warning does pop up indicating that the topic is old and may not need to be refreshed; I thought about it and proceeded anyway. It wasn’t specific to F34.

1 Like