Raspberry Pi dtparam

After installing Fedora 33 Minimal on my Pi4, I tried some tweaks where most of which worked

# /boot/config.txt
# Disable the PWR LED

# Disable the Activity LED

# /boot/efi/config.txt
# Enable boot without HDMI connected

But the command bellow doesn’t work

# /boot/config.txt
# Disable Ethernet LEDs. Pi4: 4, Pi3: 14

The output of the command sudo lshw -class network shows driverversion=5.9.13-200.fc33.aarch64. I installed Centos 8 Stream on my Pi and it runs version “2 something” of the same driver, and that version support all the dtparam above.

           description: Ethernet interface
           physical id: 3
           logical name: eth0
           serial: dc:a6:32:d5:e5:d6
           size: 1Gbit/s
           capacity: 1Gbit/s
           capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=bcmgenet driverversion=5.9.13-200.fc33.aarch64 duplex=full ip= link=yes multicast=yes port=MII speed=1Gbit/s

Why do you guys think that a newer version wouldn’t support that? I know that things change, but that’s a cosmetic thing that wouldn’t affect the operation of the hardware.
Where (which github repo) can I suggest a patch for the driver?

ps: I know Pi4 isn’t officially supported by Fedora 33 yet.

1 Like

Sorry but I’m not an expert.
Yes, it doesn’t work also for me. :pensive:

The point is this. But not only. As far as I understand, Fedora Linux uses the upstream kernel and not the one customized by the Raspberry Foundation. So, as far as I can understand, if some option we can find in various web sites is not included in the upstream Linux kernel, it doesn’t work.

Btw, again I’m not an expert, but if you look at the RPi4 dtb shipped with the kernel
fdtdump /boot/dtb/broadcom/bcm2711-rpi-4-b.dtb | grep eth
There are not references to eth_led*
If you look at the one shipped with bcm2711-firmware
sudo fdtdump /boot/efi/bcm2711-rpi-4-b.dtb | grep eth
there are some references

eth_led0 = <0x0000002b 0x6c65642d 0x6d6f6465 0x733a3000>;
eth_led1 = <0x0000002b 0x6c65642d 0x6d6f6465 0x733a3400>;

As far as I can understand, the one loaded by Fedora is the dtb inside /boot/dtb/. However, replacing this one with the one in /boot/efi doesn’t solve the question. Even if something seems to have changed.
dtc -I fs /proc/device-tree | grep eth

eth_led1 = "\0\0\0+led-modes:4";
eth_led0 = "\0\0\0+led-modes:0";

What does that mean?

However, the only way I’ve found to shutdown the NIC LEDs (and it actually works) is this tool: mdio-tool, but meh… maybe it is better to apply a sticker or use a stencil to cover the LEDs :sweat_smile:

Base on the documentation I think it means “blink when there’s activity and it’s negotiated on 100,1000Mbtis”.

    eth_led0                Set mode of LED0 - amber on Pi3B+ (default "1"),
                            green on Pi4 (default "0").
                            The legal values are:


                            0=link/activity          1=link1000/activity
                            2=link100/activity       3=link10/activity
                            4=link100/1000/activity  5=link10/1000/activity
                            6=link10/100/activity    14=off    15=on


                            0=Speed/Activity         1=Speed
                            2=Flash activity         3=FDX
                            4=Off                    5=On
                            6=Alt                    7=Speed/Flash
                            8=Link                   9=Activity

    eth_led1                Set mode of LED1 - green on Pi3B+ (default "6"),
                            amber on Pi4 (default "8"). See eth_led0 for
                            legal values.

Thanks for the answer

On the RPi4 it should be 0 and 8 :thinking: