Random pixels appearing when screen redrawn

Hi,

I run Fedora 39 on a Dell Precision 5560 with Intel + Nvidia GPUs as listed below:

$ lspci -n -n -k | grep -A 2 -e VGA -e 3D
0000:00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-H GT1 [UHD Graphics] [8086:9a60] (rev 01)
	DeviceName: Onboard - Video
	Subsystem: Dell Device [1028:0a62]
--
0000:01:00.0 3D controller [0302]: NVIDIA Corporation TU117GLM [T1200 Laptop GPU] [10de:1fbc] (rev a1)
	Subsystem: Dell Device [1028:0a62]
	Kernel driver in use: nvidia

I have the following Nvidia drivers installed:

$ sudo dnf list --installed | grep nvidia
akmod-nvidia.x86_64                                  3:545.29.06-2.fc39                @rpmfusion-nonfree-nvidia-driver               
kmod-nvidia-6.5.12-300.fc39.x86_64.x86_64            3:545.29.06-2.fc39                @@commandline                                  
kmod-nvidia-6.6.9-200.fc39.x86_64.x86_64             3:545.29.06-2.fc39                @@commandline                                  
nvidia-gpu-firmware.noarch                           20231211-1.fc39                   @updates                                       
nvidia-modprobe.x86_64                               3:545.29.06-1.fc39                @rpmfusion-nonfree-nvidia-driver               
nvidia-settings.x86_64                               3:545.29.06-1.fc39                @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia.x86_64                           3:545.29.06-2.fc39                @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-cuda-libs.x86_64                 3:545.29.06-2.fc39                @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-kmodsrc.x86_64                   3:545.29.06-2.fc39                @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-libs.x86_64                      3:545.29.06-2.fc39                @rpmfusion-nonfree-nvidia-driver               
xorg-x11-drv-nvidia-power.x86_64                     3:545.29.06-2.fc39                @rpmfusion-nonfree-nvidia-driver

… and the following mesa drivers:

$ sudo dnf list --installed | grep mesa
mesa-dri-drivers.x86_64                              23.3.2-7.fc39                     @updates                                       
mesa-filesystem.x86_64                               23.3.2-7.fc39                     @updates                                       
mesa-libEGL.x86_64                                   23.3.2-7.fc39                     @updates                                       
mesa-libGL.x86_64                                    23.3.2-7.fc39                     @updates                                       
mesa-libgbm.x86_64                                   23.3.2-7.fc39                     @updates                                       
mesa-libglapi.x86_64                                 23.3.2-7.fc39                     @updates                                       
mesa-libxatracker.x86_64                             23.3.2-7.fc39                     @updates                                       
mesa-va-drivers.x86_64                               23.3.2-7.fc39                     @updates                                       
mesa-vulkan-drivers.x86_64                           23.3.2-7.fc39                     @updates

Kernel version is x86_64 Linux 6.6.9-200.fc39.x86_64.

Recently, within the last week, the display has been flickering like crazy when the screen is updated (repainted) like when I move the mouse, or during boot when there is the spinner. At random times the screen will go black and I will need to close and reopen the lid to get something back on the screen.

I am using Wayland (as it’s the default) but this issue occurs on Xorg as well.

When I use an external monitor, there are no random pixels on it, but the main display continues to flicker and black out.

I think its a driver issue because when I did the BIOS hardware test there were no issues with the flickering (and the tests didn’t pick up anything).

Here is a sample image of what’s happening. These blocks of pixels stretch all the way across the screen and are varying heights and at random positions and sometimes overlay each other. The appear and disappear quickly or slowly depending on screen updates.

I am fairly new to Fedora, having been an Ubuntu user predominantly. I tried Ubuntu in this laptop, but Fedora works much better. It’s been probably over 6 months with no issues until this problem arose.

Hoping someone can help.

Thanks.

Which desktop environment are you using Gnome, KDE?

Do you see any errors reported from nvidia in the sudo dmesg?

I do not know timing in relation to when the kernel was updated to 6.6.9 and when this problem started. but my first suggestion would be to redo the actual driver, involving 2 steps.
sudo dnf remove kmod-nvidia-6.6.9-200.fc39.x86_64
followed by
sudo akmods --force

Once akmods completes then wait about a minute then reboot.

You now should have a completely new driver loaded and hopefully it will solve the reported issue.

Personally I also add the cuda driver with sudo dnf install xorg-x11-drv-nvidia-cuda as well.

It’s Gnome and sudo dmesg | grep nvidia does not report any errors. Thanks for your help.

Thanks for your suggestion however it didn’t work. I have a 6.5.x and 6.6.6 (:imp:) kernel installed but booting into them and rebuilding the kmods didn’t help. I tried live booting to Ubuntu and it didn’t even show anything (black screen) and also CromeOS Flex and it had the flickering issues. The BIOS screens don’t have these issues, and neither does a Windows 11 installation USB. Live booting Fedora didn’t work either.

I’m flummoxxed (so much so that I don’t even care if that’s mispelled :slight_smile: ).

I’m wondering if there is a way of turning off the NVIDIA card only and just using the Intel one. Or if there may be some boot settings (Grub options) that I might try.

FYI this problem occurs when the Grub boot selection screen is shown, as well as if I switch to another TTY with Ctrl + Alt + F3.

I might try Windows on another SSD and see what happens.

I think this is a hardware issue as when I slowly open and close the screen while moving a mouse the intensity changes. It is under warranty so it will be repaired. Thanks fo your help.