Question about launching .desktop files from desktop folder

Dear community,
As stated in the topic, I would like to run graphical application from icons on my desktop screen in my Fedora 36 Desktop 64-bit system with Gnome version 42.4. Since desktop icons were not enabled right after installation, I installed some time ago the Gnome extension “Desktop icons neo” (for reference, here is its website: GitHub - DEM0NAssissan7/desktop-icons-neo: A fork of [Desktop Icons NG]( Adds a whole bunch of new features and polish. These changes include curved edges, customizable icon shapes, extensive desktop customization in general, performance improvements, and bug fixes. The main goal of this project is to make the desktop icons feel like a part of GNOME and not a separate entity. ) that re-enables them.
I would like to have custom .desktop files that I can run directly from my desktop screen. If I create them and double click on them, I am unable to run them and they are opened in a text editor. I made sure that the files are properly formatted and modified permissions to allow them to be executed as a program, to no avail. I had found a way to make this work in the past, but I don’t remember anymore how I did that and what steps I need to reproduce.
Does any of you have any suggestion? Thank you in advance.

Welcome to ask.fedora @loregu

Please give this a try:

Since you previously had experience in establishing desktop folders and examined your files for correctness, I would venture to say the extension may be the problem. The extension mentioned does have its faults. Check this site - in particular the demonstrations - whether it offers what you want. If so,

dnf install desktopfolder

That said and to intercept comments that may follow, elimination of desktop folders follows the philosophy of the Gnome team. The next elimination that I look forward to is the topbar: waste of real estate. Do a search and you’ll find the answers so no need to dwell on that any longer.

EDIT: If app is installed, use ALT+SPACEBAR and select “Always on Visible Workspace” to pin it to all workspaces.

Hello. Thank you for your help. I had already tried but unfortunately it doesn’t change anything.

Hello Ptrck Lhrtr.
Thank you very much for your valuable suggestion. I will look more closely at the software you mentioned, because it seems versatile and very customizable. I read that it is not fully compatible with Wayland, but this may not be a problem for me.

When you right click is there an “allow launching” selection?

There appear to be some more updated versions extensions providing that functionality.
Desktop Icons NG or GTK4 Desktop icons NG.

As another alternate way:
You could copy the original desktop file from /usr/share/applications to ~/.local/share/applications
rename the file, and modify the name and what’s be executed in the file. That could be launched via the overview (super key) or via all applications (super +a)

The most usable way I found was to just use the Gnome keybinding in the settings app. You can make key bindings for your desired apps and launch them with a few keystrokes.

1 Like

The Gnome way, as I indicated, is not to have desktop folders. The answer provided by @grumpy should be followed. For instance, besides the default xterm installation, I have xterm-ii in /usr/local/bin which was compiled with a different configuation (such as sixel graphics on). In ~/.local/ share/applications is my xterm-ii desktop file. Try to test your files using this directory.

One advantage of Fedora/Linux is that you can buck the trend and do it your way. There are some who still use Classic Gnome and I’m still using XTerm. So if you’re determined to use desktop folders, so be it.

I downloaded desktopfolder and tested in X11 and Wayland. The only problem I’ve encountered - in Wayland - so far is with workspaces. My normal setting is

Settings --> Multitasking --> Dynamic workspaces

but I was limited to two. After exitting desktopfolder and toggling the workspace settings, Dynamic workspace returned.
I used some of my old destop folder files and they worked fine. What app are you using and what pertinent settings (i.e., not all of them; Exec would be one) are used in the files.

Thank you all for your suggestions and your time.
I am marking @grumpey 's post as solution because it solved my problem and it seems to me to be most fit for the specific question I asked. As he mentioned, I was probably using some old not updated fork of the extension and the “allow launching” option did not show up for some reason. I found out that I could still make it work by setting the file as trusted with something like
gio set mydesktopfile.desktop metadata::trusted true
but updating my extensions restored that selection and there was no more need for that.
@ptrck4193 I think that I will keep my desktop folders for now and use desktopfolder (this seems to work fine for me), but I may drop them in the future.