[QCA9377] I have slow wifi on Fedora 39

Hi, i just installed fedora onto my laptop and my wifi connection is about 1/10 what it should be. i didnt have this problem with windows or linux mint on the same machine nor do i have the problem when using an ethernet cable. just wifi on fedora.

here are my specs
Kernel: 6.8.6-200.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
v: 2.40-14.fc39
Desktop: GNOME v: 45.5 Distro: Fedora Linux 39 (Workstation Edition)
Type: Laptop System: Dell product: Inspiron 3593 v: N/A
Mobo: Dell model: 0TGVJN v: A00 serial: UEFI: Dell
v: 1.30.0 date: 03/07/2024
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel port: 3000 bus-ID: 01:00.0
IF: enp1s0 state: down mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel bus-ID: 02:00.0
IF: wlp2s0 state: up mac:

i have tried

  1. turning ipv6 off
  2. removing ath10k firmware 6
  3. connecting to other wifi networks
  4. turning battery saver mode off
  5. updating bios to the latest version

if anyone could help me that would be great. thank you.

I have the same card as you do and probably the same problems. I tried out some things with Void Linux, I don’t know how they work because I didn’t get too deep on it, but it could give someone a clue.

I tested different network managing services. When I used NetworkManager, IWD, and ConnMan, every single one of them only gave me 30 Mbps of download speed. wpa_supplicant with dhcpcd gives me 188 Mbps, which is limited by the distance from the router.

1 Like

Added wifi

Try upgrading to Fedora 40 and check if the issue persists.

Added realtek

How and what specifically? It sounds like possibly disabling wifi power management or BT coex may help.