PS/2 mouse freeze after sometime

Hi fedora forum users, this is my first post :sweat_smile:
I am using fedora workstation 39 (Gnome) and after booting and using my pc my PS/2 mouse freeze the only way to “unfreeze” it is to sleep then wake up my computer (i do it from my keyboard) and yes my keyboard and applications works fine only my mouse freeze i have the following error code in my logs :

Message : psmouse serio1: Failed to enable mouse on isa0060/serio1
Kernel Device : +serio:serio1
Priority : 4

And here is my /proc :

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name=“ImPS/2 Generic Wheel Mouse”
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input4
U: Uniq=
H: Handlers=mouse0 event3
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

I jus want to add that i tried the same mouse with ubuntu 23.10 and i did have the same problem “mouse freezing” so i think it’s related to gnome

Many thanks

You stated this is a PS2 mouse. PS2 is rather dated tech.
Have you tried a more current USB mouse. ?

Hi Jeff V,
When i was running F38 i used a usb mouse without problems, but i need to use a PS/2 mouse to free some USB ports and want to add that i also use a PS/2 keyboard without issues? what i feel strange is that both my mouse and keyboard are PS/2 but only my mouse have issues

On all recent motherboards I have seen those with a PS2 port only seem to have one port and it has been necessary to use a splitter cable to connect both mouse and keyboard. Is that your config? Or does your board have 2 PS2 ports?

Usually a USB hub (powered or unpowered) is low enough in cost to make their use reasonable to gain additional USB ports.

I have a somewhat relatively old config i5 2300 + Asrock H61M-VG3 (and yes it have two PS/2 ports) one dedicated for keyboard and one dedicated for mouse

And i opted for a PS/2 keyboard and mouse because peripherial connected to a pcie expansion card aren’t detected by BIOS no boot key etc …

True, but there are many external usb hubs that simply plug in and add extra ports.

Is the bios updated? I note that there is version 1.90 as the latest. This usually can be seen with inxi -SM

I understand that this problem did not appear in F38 and began after updating to F39? Or is this a new install and never previously used linux?

I don’t see much to tell us what triggered the errors.

My motherboard is already at 1.90, And no this problem did not happen on F38 because i was using a usb mouse :confused: