PrtSc shortcut key quit working after upgrading to F35

I upgraded to F35 about a week ago and after doing so, the PrtSc shortcut key for screenshots quit working. I had to go back into the Keyboard settings and remap all of the screenshot shortcuts – after which, they didn’t look any different in the list, but PrtSc now worked. I know there were some changes to the screenshot API from Gnome 40 → 41 – is anybody else seeing this issue?

My laptop is a Lenovo ThinkPad X1 Carbon G7.

1 Like

Hi @kensey Welcome. Which prtscr app do you use (installed?)

@jpbn By default in GNOME, the Print Screen key is bound to the GNOME screenshot tool.

I haven’t noticed this problem… but because of the prominent location of that key on Lenovo laptops, I actually want it disabled, because otherwise I end up with a dozen surprise screenshots per day. So I hope someone else can help. :classic_smiley:

I do use prtscr (Gnome screenshot) often, and the keys did not change after upgrade. That is why I asked for the name of the application.
In Gnome-settings is the way to change the keys for Screenshot. (disable or use differnet key(s))

I don’t use anything but the built-in GNOME screenshot tool — that’s where I had to remap all the keys to get them to work again.

To be clear, the mappings were all there, they just didn’t work until I reset them to the same things.

1 Like

Hi @kensey and @mattdm your problems are solved now ? Nobody did report the issue of @kensey.

I’m not aware of any other reports like this. There is a bug in GNOME Settings where if you open the Keyboard panel and do not have an Alternate Character Key set, that will suddenly be set to Right Alt. (Surprise!) But I don’t think there’s a corresponding problem with PrtSc.

@kensey You’re saying that when you went to Keyboard | Keyboard Shortcuts in settings, the options under Screenshots were all in their default state, but you had to redo them to make them actually work?

Exactly so. It was a relatively minor annoyance but I was puzzled for several minutes. I know the PrtSc screenshot shortcut key was working as recently as two or three days prior to the upgrade and this was the first time I had tried it since.

It also seems that every shortcut just takes a full screenshot now, i.e. although the modifier keys were captured when setting the various shortcuts, they’re not actually being recognized in use, though I need to go back and reconfirm this is an actual behavior change by comparing with an older install (F33) on my other laptop.

It may also be relevant that I’m using GNOME with Xorg rather than Wayland.

Huh. I guess at this point all I have is “woah, that’s weird”.

I’ll keep an eye out for anyone seeing similar!

1 Like

This just occurred again. I think it recurred after I rebooted. Same issue, same fix.

1 Like