Problem with NetworkManager and vpn after last update (F38):

I had F38 install and running ok. I just did an update, and now I can’t connect to any previously imported vpns. I could yesterday, but now, when I try to connect I get a dialog asking for credentials, which I never had been before.

I am using NordVPN. I have tried re-importing their .ovpn’s into NetworkManager, but I still get the dialog.

If I use their command line tools, I can make a connection , but it connects using wireguard.

This has really screwed me up. Anyone have any ideas?



Added networkmanager, vpn

Check if NordVPN changed from OpenVPN to wireguard only? These dialogs often appear if the previous authentification didnt work. Also try to download new config files.

Mullvad nearly only has Wireguard too now.

This doesnt sound like a Networkmanager issue.

The request is coming from NetworkManager. What I don’t know is what password it is asking for.

NordVPN has WireGuard - they call it “nordlynx”. It also still has OpenVPN. NetworkManager should be using that (openvpn), or at least requesting that, since I see no wireguard config files n NM’s connections folder. But I think this issue will be resolved if I find out what password is being asked for. I have never had to enter a password before.

As NordVPN now has wierguard, what I need now is to figure out how to set up a NM connection, then I can ignore OpenVPN.

Thanks for your help


If you need to enter a password this is always the fallback solution. For example when usint git with ssh but the key is not found. Just because a prompt appears doesnt mean you will be able to authenticate with a password.

It seems that Networkmanager may have registered a Wireguard connection? But probably not.

Try to find wireguard config files from NordVPN.

Also note this discussion about a VPN killswitch, which is pretty important.

It seems to have fixed itself. Maybe nordvpn had changed something? I don’t know. But now I don’t get asked for some password. But this is still using OpenVPN.

I tried to set up an NM wireguard connection, but nothing worked.The only way I could use wireguard is through NordVPN’s app. But it is difficult to connect/disconnect the vpn withouth causing network problems. OPenVPN is fine for me for now. So it’s not broke, and so I won’t try to fix.

Thanks for the help.


PS: about the kill switch. You can’t set up one with NM. That is NM’s fault.