Has anybody had any luck configuring Huawei's SSL VPN with NetworkManager?

Reference: https://support.huawei.com/enterprise/en/doc/EDOC1100086057

In the end, this is an HTTPS VPN; pretty similar to those available using the OpenConnect plugin. I haven’t been able to make it work, though.

I got as far as making it ask for a user/password combination but, when I try to connect, it just fails saying it cannot find an auth node.

So, for example, I configured an OpenConnect VPN. I added the gateway-ip:port and hit connect. I get this message:


Then, I trust this self-signed certificate and try to go on and I get this:


If anyone has any ideas or pointers, let me know.

You can also try fortisslvpn or vpnc as mentioned here.
In the worst case, you need a VM running Windows.

Thank you for responding.

The thread you suggested suggests it doesn’t work.

That said, I still tried. Networkmanager-vpnc requires a group name; which I don’t have.
NetworkManager-openconnect seems the one closest to working. I tried all variatons (including fortisslvpn) and nothing worked.

Just to let know others your suggestion doesn’t solve it. Thank you for trying, though.

I’ll try, as suggested at Reddit, to post at their forum and see if they give me a solution to this.

1 Like

In the worst case, you need a VM running Windows.

Yeah… no.

Tried registering on their forum but couldn’t. I tried using Firefox and Chrome. Nothing worked. :frowning:

1 Like