Problem building kickstart ISO


I am working on build customized Fedora ISO live CDs images and I had a strange behavior here.

At first, I did the following procedure:

  • Installed Fedora34 Workstation on my machine
  • Installed livecd-tools
  • Installed spin-kickstart
  • Copied the directory /usr/share/spin-kickstart to my home directory
  • Ran the following command:

sudo livecd-creator --verbose --config=fedora-live-security.ks --fslabel=SecuritySpin --cache=/var/cache/live

Everything when well. I could save the iso generated file to a pendrive and started the livecd.

But, then I did the following:

  • Upgraded my operating system, using Gnome Software Update tool
  • Run again the same livecd-creator command

The build process went well, similar to the previous one.

But in this case, when I loaded the pendrive, the system does not boot.

After some time, I have the error message “Failed to listen on udev kernel socket”.

Is there any explanation about why the new ISO fails to work after upgrading the host system?

Best regards,


Welcome to ask fedora.

I think your problems goes in this direction:

From F33 to F34 changed the grub2 path. Please check your script.

Hello @ilikelinux ,

I am always using Fedora 34.

This problem happens when I execute a full upgrade of my Fedora host.

Here is the picture of what happens:

I have also trying forcing a specific release version on livecd-creator command:

sudo livecd-creator --verbose --config=fedora-live-security.ks --fslabel=SecuritySpin --cache=/var/cache/live --releasever=34

At least for now my solution is to avoid software upgrade on my host system.

Any idea?

Best regards,


Is your PC properly connected to the internet?

If it is then please post the complete text seen when you issue the commands

uname -a
sudo dnf update

The snippet seen in your screenshot is not adequate to assist in trouble shooting or fixing the problem.

Hello @computersavvy ,

The screenshot is showing what happens when I try to load the generated ISO.

I believe that was the only way to show the issue.

Now the text for the requested commands when the Operating System is creating a working ISO:

[flavio@fedora ~]$ uname -a
Linux fedora 5.11.12-300.fc34.x86_64 #1 SMP Wed Apr 7 16:31:13 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
[flavio@fedora ~]$ sudo dfn update
[sudo] password for flavio: 
sudo: dfn: command not found
[flavio@fedora ~]$ uname -a
Linux fedora 5.11.12-300.fc34.x86_64 #1 SMP Wed Apr 7 16:31:13 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

The content for the second command is here:

I could not add here due text lengh limitations.

Please tell me if you want the execution of the update too. I didn’t add here because I ran out of internet for some minutes which messed the text.

Best regards,


Hello @computersavvy ,

Here is the file containing everything: Fedora Complete Update - 8a889ad8

After rebooting the machine, I got this:

[flavio@fedora ~]$ uname -a
Linux fedora 5.14.11-200.fc34.x86_64 #1 SMP Sun Oct 10 14:39:31 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
[flavio@fedora ~]$ 

Here is the output of the build:

The generated image in boot provided the same response from the image.

What can the upgrade be causing that the generated ISO is no longer working.

Best regards,


sudo dnf update … there is a small typo.

Hi @ilikelinux ,

Indeed … but if you look at the pastebin link, I corrected that and all the requested information is there.

I was unable to paste the text here.

I don’t work with kickstarts and creating ISOs so cannot help with that. Your posted output in the pastebin showed you had not updated the the initial fedora 34 install at all (kernel 5.11.12 was the initial kernel on the F34 ISO) before you ran the upgrade at my suggestion.

I cannot help with advice other than to suggest you look at what you are building and see if something that is needed is missing and if so then install it.

There were several threads in the past on this forum about kickstarts and building ISOs so that may be a point to start researching.

Hi @computersavvy . Thank you for your fast response.

I haven’t found similar behavior reported in the past. That’s what motivated my post.

I got the Fedora Workstation ISO from Fedora website :expressionless:

My understanding is that I touched nothing in any kickstart script and a simple software update (as large as it might be, but still in the same release) is breaking things. At least this post could be an error report.

Best regards,


Hi @ilikelinux ,

I believe I forgot to mention: I didn’t change anything on kickstart spins scripts.

Best regards,


The kickstart script itself may be failing due to software changes done by the upgrade. You might have to dig there.

The overall upgrades with F34 have obsoleted several packages and added others so that may be the source of the problem.

Hi @computersavvy ,

Got it. I will start to look at the starting point suggested by @ilikelinux.

Best regards,


Hi Flavio, it wasn’t just the update that changed between the builds. IIRC livecd-creator uses lorax and anaconda under the hood, so its build will grab packages directly from the repositories, not take what you have installed on your system. So, if the contents of the repository changed between your two builds, there’s another difference.

You can examine /var/log/anaconda/packaging.log on the built ISOs to find versions of packages that went into them. If there’s a difference in the stuff related to booting, congratulations, you have another variable in the problem :-/ You could probably try forcing the old versions by editing the kickstart and setting them there.

I could have a bootable version now.

What I did was to change the repository location, in the file fedora-repo.ks, replacing fedora-repo-rawhide.ks to fedora-repo-not-rawhide.ks.

Then I ran the following command:

sudo livecd-creator --config=fedora-live-security.ks --fslabel=SecuritySpin --cache=/var/cache/live --releasever=34

The resulting generated iso booted, finally. But I got several errors related to Loading Kernel Modules. I am trying fo figure out how to solve this.