Pop shell on Fedora 39

Good afternoon,
I wonder if anyone can help me. I have just upgraded to F39 workstation from F38. Before the upgrade the Pop Shell extension was working fine. Now after the update in the Extensions app it is saying that the Pop Shell extension is not compatible with this version of Gnome.
Does anyone know what I can do about this as I am really missing the tiling features.
Thanks for any help,


If the extension is critical to your workflow, then it would have been wise to wait upgrading until also the extension was ready for the new version of Gnome Shell.

The best solution, I guess, would be to reinstall F38 so you can continue using the extension.


  • You could check on the page of the extension itself if a newer version is already available. There is a delay before an updated extension makes it to the Gnome Extensions website.

  • You could try whether merely adding the version of the current version of Gnome Shell in the metadata.json file of the extension allows the extension to run. That really depends. It could work, it could work partly, it could work not at all, it could work and make your system unstable…

Since System76, supporters of POP!_OS and the Pop Shell, is building their own DE from scratch (COSMIC), they dropped support for Pop_Shell on GNOME. As any Open-source project, is open for anyone to pick up and maintain (I asked if someone was willing).

That being said, GNOME’s window-tiling have been improving quite a bit and, hopefully, extensions like the Pop_Shell are no longer necessary.

GNOME’s window-tiling have been improving quite a bit

I do not see where: I still can tile only to the left or to the right. Perhaps there are more possibilities now when dragging a window to a corner, but I disabled that.

Whatever, it is still a very far cry from an experience close to that of a tiling manager that the Pop Shell extension was able to implement. There are a few extensions out there for Window tiling, which OP could try.

Due to the fact I may have slightly more intelligence than you give me credit for I had indeed tried a fresh install of F39 on another machine and the Pop Shell extension worked flawlessly.

I have now done a fresh install of F39 on my main machine and the Pop Shell extension is working flawlessly.

There was obviously some issue that occurred during the upgrade process from F38 to F39 that caused the extension to not work.

Anyway, I now have my tiling back for which I am very grateful as it makes using an ultrawide monitor far easier.

Thanks for the replies,


1 Like

This is denigrating the validity of the comment you were referring to.

Since you had not stated explicitly that you had done what was suggested and had not given details of your preparation and testing with the results, the observation by @ytrium was perfectly valid.

The rules on this forum are that we try to be excellent in our comments and never say anything that impinges on the individual, but always focus on the problem – never the person.

Please ensure your posts live up to the expected standards.

In this particular case, you might have shared that you had tried a clean install and it worked as expected, but that the upgraded system did not work the same. Doing so would have given everyone more opportunity to focus on what the actual cause and the surrounding circumstances were. Without that information it seems quite reasonable to believe the extension had not yet been fully upgraded for the new version of gnome.